summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-11 12:36:22 +0100
committerSam James <sam@gentoo.org>2023-10-11 12:36:22 +0100
commita8dfb299534aafde03447dfdd968c1b2d68af4cf (patch)
tree9b9199680a160017ec1027aa12521e11440ec936
parentgames-simulation/simutrans: make midi support optional (diff)
downloadgentoo-a8dfb299534aafde03447dfdd968c1b2d68af4cf.tar.gz
gentoo-a8dfb299534aafde03447dfdd968c1b2d68af4cf.tar.bz2
gentoo-a8dfb299534aafde03447dfdd968c1b2d68af4cf.zip
sys-apps/moar: add 1.18.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.18.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index 0aa54b361dda..30b1c53a218b 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -2,3 +2,5 @@ DIST moar-1.16.2-deps.tar.xz 4760036 BLAKE2B 6fd72d710a620fdf104766be84f3fa68652
DIST moar-1.16.2.tar.gz 2782878 BLAKE2B f713e13f9729ab6fb17a1f297551b765ee4a19d1fd7ae2da949d489a37fb2e91c0958cfe4ce4c4a57339dedadc1b77d276464a87522ede1c451cc906ed9a4d51 SHA512 934696264082d72b202339d2b30b0f382cb7ef7a1b3985d5fb23f8dd81306c657c4bd24c59c1338a090a56ae2af53dc0d576f2c482b33f782f27434add50b222
DIST moar-1.17.1-deps.tar.xz 4760036 BLAKE2B 6fd72d710a620fdf104766be84f3fa68652c760818cdee66bb8475cc8949872c82be026c04b54cb61c0108c5977cb1f787f9a4fa0316bde0293cdedb1f6f94f8 SHA512 f40520a1b2e94f4a3e97d6a4e19191484b66e13a57c7b30416c813d84cad3d29295e862d5b75870313cc905112425c731d052619d49e78b33fb3d5d8750df3df
DIST moar-1.17.1.tar.gz 2784584 BLAKE2B 486520a89969bde12bed683e28fd37a90d32b35ecc80261901595ccfe9d12deb26c307404ba0505919b1a35c237e07b59aa5469f04b51bd12d6e71e39571b648 SHA512 f502e930cf78c86eccacb4c23b1d4874bb39d5add2b36dbaa5426d269b5a315204782e1f539262f04adab510d177e374fcf9ff79df5ba2974f32e513e8d56fd6
+DIST moar-1.18.0-deps.tar.xz 4760036 BLAKE2B 6fd72d710a620fdf104766be84f3fa68652c760818cdee66bb8475cc8949872c82be026c04b54cb61c0108c5977cb1f787f9a4fa0316bde0293cdedb1f6f94f8 SHA512 f40520a1b2e94f4a3e97d6a4e19191484b66e13a57c7b30416c813d84cad3d29295e862d5b75870313cc905112425c731d052619d49e78b33fb3d5d8750df3df
+DIST moar-1.18.0.tar.gz 2784174 BLAKE2B 3d9ee7fda27419b419f47bae3336d9f0d7ae48bbdad1fb8c501c85b4ea34aaaf6cf1c865f1b56d195ec6e129333d63e552d96b147fb9c26c739482a546d6286e SHA512 a76f19465d03deec8f778fda213be6ab33fdd48d309231f4f0ad0cdd8ea2facc41e2bdb1b74771c4a9ce3a31c30a72754f790e5eb9edb06e19d26fe3e224b507
diff --git a/sys-apps/moar/moar-1.18.0.ebuild b/sys-apps/moar/moar-1.18.0.ebuild
new file mode 100644
index 000000000000..091d314e2ac3
--- /dev/null
+++ b/sys-apps/moar/moar-1.18.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}