summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-04-20 17:29:06 +0100
committerMatthew Smith <matthew@gentoo.org>2022-04-20 17:29:06 +0100
commita8e0338856cd3f7b81a535385ce1ddde4e034e53 (patch)
tree74d184e87b08050cffe3c6e81908e77480a7aa44
parentapp-emacs/org-mode: add 9.5.3 (diff)
downloadgentoo-a8e0338856cd3f7b81a535385ce1ddde4e034e53.tar.gz
gentoo-a8e0338856cd3f7b81a535385ce1ddde4e034e53.tar.bz2
gentoo-a8e0338856cd3f7b81a535385ce1ddde4e034e53.zip
app-emacs/vertico: add 0.22
Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--app-emacs/vertico/Manifest1
-rw-r--r--app-emacs/vertico/vertico-0.22.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/vertico/Manifest b/app-emacs/vertico/Manifest
index 2ba3717a0e58..6d553fad78f7 100644
--- a/app-emacs/vertico/Manifest
+++ b/app-emacs/vertico/Manifest
@@ -1 +1,2 @@
DIST vertico-0.20.tar.gz 40899 BLAKE2B 73f42eefc43095c58c38570fac2fc915f7a1d7095f2b1864834eb57d658114ee3a4a98fb834c64793810505e171602801d8a492eecc7349137833442fc02b715 SHA512 0e683a572fec4ba223f03672461b4888667e35202dd1b2efc139127d3327d6d7a6d7eab96549239e6dad6e86054854b49a3be553ce482fd2e683bdb029e3a9c0
+DIST vertico-0.22.tar.gz 42487 BLAKE2B f6863b4078f25fba318685fd16a34abe016c9fb9fd94a7ad6fcbce02c72526786c74f67177a44433ee5aa747382db81762015fcfe98da252f19aa88f219d294d SHA512 108348cb43f07909570dd40e058c1ea612c6a8c39794a365ef0ee0111d7f43dde37f82c46bcac0319eba44e6e5553bde2bc09f8755bb1e3f4b22999fdacc23c2
diff --git a/app-emacs/vertico/vertico-0.22.ebuild b/app-emacs/vertico/vertico-0.22.ebuild
new file mode 100644
index 000000000000..d2415e174e28
--- /dev/null
+++ b/app-emacs/vertico/vertico-0.22.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Vertical interactive completion"
+HOMEPAGE="https://github.com/minad/vertico"
+SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}