summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-10 10:00:35 +0100
committerSam James <sam@gentoo.org>2022-09-11 21:12:20 +0100
commita8e3d79c8d43c919bf78b3b459b4ae13e2e02e23 (patch)
tree43097bd265135171643443882b96b7ae035d5f3c
parentwww-client/chromium: Stabilize 105.0.5195.102 amd64, #868351 (diff)
downloadgentoo-a8e3d79c8d43c919bf78b3b459b4ae13e2e02e23.tar.gz
gentoo-a8e3d79c8d43c919bf78b3b459b4ae13e2e02e23.tar.bz2
gentoo-a8e3d79c8d43c919bf78b3b459b4ae13e2e02e23.zip
media-libs/flac-compat: new package, add 1.3.4
Closes: https://github.com/gentoo/gentoo/pull/27197 Co-authored-by: David Seifert <soap@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/flac-compat/Manifest1
-rw-r--r--media-libs/flac-compat/flac-compat-1.3.4.ebuild63
-rw-r--r--media-libs/flac-compat/metadata.xml11
3 files changed, 75 insertions, 0 deletions
diff --git a/media-libs/flac-compat/Manifest b/media-libs/flac-compat/Manifest
new file mode 100644
index 000000000000..b8a23c4d2cbe
--- /dev/null
+++ b/media-libs/flac-compat/Manifest
@@ -0,0 +1 @@
+DIST flac-1.3.4.tar.xz 1038356 BLAKE2B 0553cd42705f31d6a98d10e8b73953265e97c6b1e46bb59c7d97d12ec1b4aae4c3d6f5e85b9e5d1513f7efac82a65ea9dc59d89d8df0254ff3ab1188039c55c5 SHA512 4a626e8a1bd126e234c0e5061e3b46f3a27c2065fdfa228fd8cf00d3c7fa2c05fafb5cec36acce7bfce4914bfd7db0b2a27ee15decf2d8c4caad630f62d44ec9
diff --git a/media-libs/flac-compat/flac-compat-1.3.4.ebuild b/media-libs/flac-compat/flac-compat-1.3.4.ebuild
new file mode 100644
index 000000000000..90107a61cc6d
--- /dev/null
+++ b/media-libs/flac-compat/flac-compat-1.3.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="Free lossless audio encoder and decoder"
+HOMEPAGE="https://xiph.org/flac/"
+SRC_URI="https://downloads.xiph.org/releases/${PN/-compat}/${P/-compat}.tar.xz"
+S="${WORKDIR}/${P/-compat}"
+
+LICENSE="BSD FDL-1.2 GPL-2 LGPL-2.1"
+SLOT="8.3.0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cxx ogg cpu_flags_x86_sse"
+
+RDEPEND="
+ !media-libs/flac:0/0
+ ogg? ( media-libs/libogg[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/xz-utils
+ sys-devel/gettext
+ virtual/pkgconfig
+ abi_x86_32? ( dev-lang/nasm )"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-debug
+ --disable-altivec
+ --disable-vsx
+ --disable-doxygen-docs
+ --disable-examples
+ --disable-xmms-plugin
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable cxx cpplibs)
+ $(use_enable ogg)
+
+ # cross-compile fix (bug #521446)
+ # no effect if ogg support is disabled
+ --with-ogg
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ if [[ ${UID} != 0 ]]; then
+ emake -j1 check
+ else
+ ewarn "Tests will fail if ran as root, skipping."
+ fi
+}
+
+multilib_src_install_all() {
+ rm -r "${ED}"/usr/bin || die
+ rm -r "${ED}"/usr/include || die
+ rm -r "${ED}"/usr/share || die
+ rm -r "${ED}"/usr/lib*/pkgconfig || die
+ rm -r "${ED}"/usr/lib*/*.so || die
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/media-libs/flac-compat/metadata.xml b/media-libs/flac-compat/metadata.xml
new file mode 100644
index 000000000000..e2a8eda2922f
--- /dev/null
+++ b/media-libs/flac-compat/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">flac</remote-id>
+ </upstream>
+</pkgmetadata>