summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-07 06:56:37 +0100
committerSam James <sam@gentoo.org>2023-04-07 12:24:44 +0100
commita8e480ed72b9bf8b296fc334bf1e878a4d1dd97c (patch)
treee033b41a1a0884b69325f3e3f85ebbc2a4aa745d
parentdev-ruby/mocha: enable ruby32 for 0.14.x (diff)
downloadgentoo-a8e480ed.tar.gz
gentoo-a8e480ed.tar.bz2
gentoo-a8e480ed.zip
dev-ruby/globalid: enable ruby32
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ruby/globalid/globalid-1.1.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/globalid/globalid-1.1.0-r1.ebuild b/dev-ruby/globalid/globalid-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..22e6caa87ce0
--- /dev/null
+++ b/dev-ruby/globalid/globalid-1.1.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="globalid.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Reference models by URI"
+HOMEPAGE="https://github.com/rails/globalid"
+SRC_URI="https://github.com/rails/globalid/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bundler >=dev-ruby/activemodel-5.0 >=dev-ruby/railties-5.0 )"
+ruby_add_rdepend ">=dev-ruby/activesupport-5.0:*"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+
+ sed -i -e '2irequire "forwardable"' test/helper.rb || die
+}