summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-12 17:00:45 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-12 18:51:32 +0100
commita9089ecf7132e27cf361092b850f80c95953e2d7 (patch)
tree8abaf590f3dc36b941e12976f41705e9d8bc7fe3
parentapp-editors/mousepad: Remove old (diff)
downloadgentoo-a9089ecf7132e27cf361092b850f80c95953e2d7.tar.gz
gentoo-a9089ecf7132e27cf361092b850f80c95953e2d7.tar.bz2
gentoo-a9089ecf7132e27cf361092b850f80c95953e2d7.zip
dev-python/sqlglot: Bump to 22.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-22.4.0.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index c20bf2fb3a0f..bcbef08a4f72 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -22,6 +22,7 @@ DIST smallvec-1.11.2.crate 34801 BLAKE2B 58645e99db8f02db64d02c75860c7ea41836c42
DIST sqlglot-22.2.1.tar.gz 17761904 BLAKE2B 67cfb6333f9f4d00ed7ac4cd1c3eedfd7f374e98b63474464e01937eeae1a978fa9dc1f948cb90e26f39a4e27efc1f5c57c9a82697076f46d8c1c67bcb0d7785 SHA512 3894f1c3924c6830822788e22f6b271ac47d555a6a1d264221fba15dcfa67dc27496944568bdb202bdb7a53fc67ee8f9afc25c1ef4cc624cab144e2d49de032a
DIST sqlglot-22.3.0.tar.gz 12723662 BLAKE2B 301c2590d91c274e038d0fcce467cc6991af4a36300ae8ec9196f189d275195deb85bee11bc168ef6e979507618f73b96eb07c9f5de9d77ac06e0c291f6f2965 SHA512 21c2bb9b63b44fb6813253ac382512d45e5f6a109449b28c4ab468055217b8402fd0a2d9f39cfc09f37f7bcd7ea43828d5138a6012a5230254417d5ad1cbb32f
DIST sqlglot-22.3.1.tar.gz 12763515 BLAKE2B b4f3eba750ed44153d0032fa698b25580625cae4857ffac3fdc675304ae50cb89c576c32233982d80cae0b4cd3ad7b94e1eafd431bbaf3d5f2d1915446c49136 SHA512 511868ae992f037a0a844a940f3ccbd8b482fc6aad422bd060ab695d580504626248de8c71413c40745dedcb43020a56098d8fdadd83d649d78c33734a236a2a
+DIST sqlglot-22.4.0.tar.gz 12770391 BLAKE2B c9695cd2241b5003ea3b3dee22ea53cc690f8444f168cbca627c9993792d68addccf8e86ad95c97bc553fb886f54b6a9932a890913cf2bb220403509cb243217 SHA512 6225722ab46aadbf01f1f24b5bd4fbeedbf97a6db6262365a08ea188d9cff1eecb380c4629a69065a0e2e5a1c397969d855b8bd3553527b6b36653ac60a8c66d
DIST syn-2.0.41.crate 246016 BLAKE2B 9d389f2e2a0acb4c84c309456e8ffcc88c5d4d541535ed136832d7a6054dde45a598bb68e8a6f3062ca2a96e1ceae947d54b3aec9bad65b0c51d6733aa6c80db SHA512 6bbaf69ca783025dfb81ac3612ac60bfbed31b2d87792909b35c12892dadebdaff2ddf9463105e536b671dce5870610ab90fe29471284bbd3014dca8d6993f1a
DIST target-lexicon-0.12.12.crate 25156 BLAKE2B f3803596c75f6c89438592a1176c3748fc2c0524d7d50a20056de1cd26d40c572b05bafcdf6dd702752864bea37c8b4f28f96dadc12a5b3bb1d279b25e489f85 SHA512 6147295c43ba1b7b087a3c5ab51534b2985e4e77e5e15687978cfb9d07e21c4fd9bc7191576d6cabd268d08a44dc733c4a957e59dba8b948c2055d8bb433aeca
DIST unicode-ident-1.0.12.crate 42168 BLAKE2B 4cede03c08758ccd6bf53a0d0057d7542dfdd0c93d342e89f3b90460be85518a9fd24958d8b1da2b5a09b5ddbee8a4263982194158e171c2bba3e394d88d6dac SHA512 bc1824e1e4452a40732fc69874d7e1a66f7803717a314790dcf48867eba34bc9441331ef031e386912e52c385645c25b6ed39d4f149973b5b97371b1b96b1920
diff --git a/dev-python/sqlglot/sqlglot-22.4.0.ebuild b/dev-python/sqlglot/sqlglot-22.4.0.ebuild
new file mode 100644
index 000000000000..058fa81df816
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-22.4.0.ebuild
@@ -0,0 +1,121 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+CARGO_OPTIONAL=1
+CRATES="
+ autocfg@1.1.0
+ bitflags@1.3.2
+ cfg-if@1.0.0
+ heck@0.4.1
+ indoc@2.0.4
+ libc@0.2.150
+ lock_api@0.4.11
+ memoffset@0.9.0
+ once_cell@1.19.0
+ parking_lot@0.12.1
+ parking_lot_core@0.9.9
+ proc-macro2@1.0.70
+ pyo3-build-config@0.20.0
+ pyo3-ffi@0.20.0
+ pyo3-macros-backend@0.20.0
+ pyo3-macros@0.20.0
+ pyo3@0.20.0
+ quote@1.0.33
+ redox_syscall@0.4.1
+ scopeguard@1.2.0
+ smallvec@1.11.2
+ syn@2.0.41
+ target-lexicon@0.12.12
+ unicode-ident@1.0.12
+ unindent@0.2.3
+ windows-targets@0.48.5
+ windows_aarch64_gnullvm@0.48.5
+ windows_aarch64_msvc@0.48.5
+ windows_i686_gnu@0.48.5
+ windows_i686_msvc@0.48.5
+ windows_x86_64_gnu@0.48.5
+ windows_x86_64_gnullvm@0.48.5
+ windows_x86_64_msvc@0.48.5
+"
+
+inherit cargo distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+SRC_URI+="
+ native-extensions? (
+ ${CARGO_CRATE_URIS}
+ )
+"
+
+LICENSE="MIT"
+LICENSE+=" native-extensions? ("
+# Dependent crate licenses
+LICENSE+=" Apache-2.0-with-LLVM-exceptions MIT Unicode-DFS-2016"
+LICENSE+=" )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+native-extensions"
+
+BDEPEND="
+ native-extensions? (
+ ${RUST_DEPEND}
+ dev-util/maturin[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/sqlglotrs/sqlglotrs.*.so"
+
+src_unpack() {
+ cargo_src_unpack
+}
+
+src_prepare() {
+ # remove fragile timing check
+ sed -i -e '/assertLessEqual(time\.time/d' tests/test_parser.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ if use native-extensions; then
+ local DISTUTILS_USE_PEP517=maturin
+ cd sqlglotrs || die
+ distutils-r1_python_compile
+ cd - >/dev/null || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+ )
+
+ # make sure not to use an earlier installed version
+ local -x SQLGLOTRS_TOKENIZER=$(usex native-extensions 1 0)
+ rm -rf sqlglotrs || die
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}