summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-12-04 10:24:11 -0500
committerAaron Bauman <bman@gentoo.org>2020-12-04 10:25:53 -0500
commita90981f868b18a77750bc3017e67b405aea7a0a0 (patch)
treed0ec27759a42fc55bda0924ba48bbbd548f75fe0
parentapp-backup/backintime: add py3_{8,9} (diff)
downloadgentoo-a90981f868b18a77750bc3017e67b405aea7a0a0.tar.gz
gentoo-a90981f868b18a77750bc3017e67b405aea7a0a0.tar.bz2
gentoo-a90981f868b18a77750bc3017e67b405aea7a0a0.zip
app-crypt/certbot-dns-nsone: add py3_{8,9}. Fix DISTUTILS
Closes: https://bugs.gentoo.org/745852 Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild
index 221d334e171b..3f80a50feaa7 100644
--- a/app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild
+++ b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild
@@ -2,7 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python3_6 python3_7)
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
@@ -23,11 +26,9 @@ LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
-CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
+RDEPEND="
>=app-crypt/certbot-0.31.0[${PYTHON_USEDEP}]
>=app-crypt/acme-0.39.0[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]
>=dev-python/dns-lexicon-2.2.1[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"