summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-03 08:46:51 +0000
committerSam James <sam@gentoo.org>2023-12-03 09:01:48 +0000
commita90d5636129f5ab7c1b2ca9238edd82286d67649 (patch)
treeb8a6ab93dad1102ef999311b1545b54dac013bd3
parentdev-python/pipenv: enable pypy3 (diff)
downloadgentoo-a90d5636129f5ab7c1b2ca9238edd82286d67649.tar.gz
gentoo-a90d5636129f5ab7c1b2ca9238edd82286d67649.tar.bz2
gentoo-a90d5636129f5ab7c1b2ca9238edd82286d67649.zip
sys-apps/moreutils: add 0.68
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/moreutils/Manifest1
-rw-r--r--sys-apps/moreutils/moreutils-0.68.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/sys-apps/moreutils/Manifest b/sys-apps/moreutils/Manifest
index 9ebaa20ea2a4..ae077fe1a2f0 100644
--- a/sys-apps/moreutils/Manifest
+++ b/sys-apps/moreutils/Manifest
@@ -1 +1,2 @@
DIST moreutils-0.67.tar.gz 93627 BLAKE2B 4b8788411f1300ccffa10a52a327ee676b2a241531dafc2106495977ffd29a5b32c91c0afb6425b5797bfea04fa98a3cfd69e034cffc2fb255f5e8505d3b3474 SHA512 3a395fa80c1c1d769ec078cbf9455952201a364d8264796c6443a397ed7fa4f08250ecd140f047cf2e9533d6fc5310b3a579a7c083a5bc4cb4672d39c35dab75
+DIST moreutils-0.68.tar.gz 93732 BLAKE2B f6bac790a294f6a05624ca33906a41e60a0dcc5c25ef31f62dc501ecf39913299f6ecd64130ed4da1896342ae4bfc286b02217f68c76d0e915cd2d8f684237b1 SHA512 8d2ee4ab1e2409a4adde018c558884ff6c642c7426b1d07d5d15bf89ba42ea5aec279c01d7d80815a825adc527ceddf0de8db9c05b0392fccc8e76bcae032558
diff --git a/sys-apps/moreutils/moreutils-0.68.ebuild b/sys-apps/moreutils/moreutils-0.68.ebuild
new file mode 100644
index 000000000000..54715703df91
--- /dev/null
+++ b/sys-apps/moreutils/moreutils-0.68.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Collection of tools that nobody thought to write when Unix was young"
+HOMEPAGE="https://joeyh.name/code/moreutils/ https://git.joeyh.name/index.cgi/moreutils.git/"
+# Not available at time of release
+#SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.xz"
+SRC_URI="https://git.joeyh.name/index.cgi/moreutils.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~x86-linux ~x64-macos"
+IUSE="+doc +perl"
+
+RDEPEND="
+ !<dev-util/pwntools-4.10.0_beta0-r2
+ perl? (
+ dev-lang/perl
+ dev-perl/IPC-Run
+ dev-perl/Time-Duration
+ dev-perl/TimeDate
+ )
+ "
+BDEPEND="
+ doc? (
+ >=app-text/docbook2X-0.8.8-r2
+ app-text/docbook-xml-dtd:4.4
+ dev-lang/perl
+ )
+"
+IDEPEND="app-admin/eselect"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.64-respect-env.patch
+)
+
+src_prepare() {
+ # don't build manpages
+ if ! use doc ; then
+ sed -i -e '/^all:/s/$(MANS)//' -e '/man1/d' Makefile || die
+ fi
+
+ # don't install perl scripts
+ if ! use perl ; then
+ sed -i -e '/PERLSCRIPTS/d' Makefile || die
+ fi
+
+ default
+}
+
+src_compile() {
+ tc-export CC
+
+ emake \
+ CFLAGS="${CFLAGS}" \
+ DOCBOOKXSL="${BROOT}"/usr/share/sgml/docbook/xsl-stylesheets \
+ PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" INSTALL_BIN=install install
+
+ # sys-process is more advanced than parallel from moreutils, rename it
+ if use doc; then
+ mv "${ED}"/usr/share/man/man1/{,${PN}_}parallel.1 || die
+ fi
+
+ mv "${ED}"/usr/bin/{,${PN}_}parallel || die
+}
+
+pkg_postinst() {
+ # Try to make sure ${EDITOR} is valid for vipe (bug #604630)
+ eselect editor update
+}