summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-06-22 16:48:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2022-06-22 16:49:18 +0200
commita915c3c1af5690147351902b9c3e66481fcc45d1 (patch)
treea38bd3cd4dc514c0eb54344f73194da006c5fd20
parentsci-libs/pcl: add missing views usedep on vtk (diff)
downloadgentoo-a915c3c1af5690147351902b9c3e66481fcc45d1.tar.gz
gentoo-a915c3c1af5690147351902b9c3e66481fcc45d1.tar.bz2
gentoo-a915c3c1af5690147351902b9c3e66481fcc45d1.zip
sci-libs/rtabmap: bump to 0.20.18
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--sci-libs/rtabmap/Manifest1
-rw-r--r--sci-libs/rtabmap/files/ocv.patch30
-rw-r--r--sci-libs/rtabmap/rtabmap-0.20.18.ebuild68
3 files changed, 99 insertions, 0 deletions
diff --git a/sci-libs/rtabmap/Manifest b/sci-libs/rtabmap/Manifest
index 194e9590c789..af70c88c7b8a 100644
--- a/sci-libs/rtabmap/Manifest
+++ b/sci-libs/rtabmap/Manifest
@@ -1 +1,2 @@
DIST rtabmap-0.20.13.tar.gz 21501493 BLAKE2B eddec6e4812cea231f88263ce136eb535bc099939a482d6fb6de0e6ab3a302c395eb5f6c824d04da8d48a7f7ad9d63b8fa313ae3c21dcada74ec89c7e8130af5 SHA512 4014ec3b7bc2edbd7f361026d5a4be9222b094e398fde68512aab37b3edcb01d47256e4931de6ea1b3bcada9ac81405946e85e774220b9cf43d14a2db6c91118
+DIST rtabmap-0.20.18.tar.gz 21545395 BLAKE2B 1cd7727cc499f0c78fa62f94fca4517e9a5f1eb79e0690683da1c61536542a6d3e342794f4282c92aa725be221fd88afb1f730cc8e431bb9ac293bd73e7146cf SHA512 313b95ba741ecbbec721ce3c339b508e75578f2b85f23739d22ddda5be28c03104e9bb6c4ab8a45ac2225bd72c7b9e84b4c5a5ae7bd4d04b1bb054566be23fff
diff --git a/sci-libs/rtabmap/files/ocv.patch b/sci-libs/rtabmap/files/ocv.patch
new file mode 100644
index 000000000000..642f2e1e911b
--- /dev/null
+++ b/sci-libs/rtabmap/files/ocv.patch
@@ -0,0 +1,30 @@
+From cf64b20e1fd5b7aca6f5f708e9b790aa41e799db Mon Sep 17 00:00:00 2001
+From: matlabbe <matlabbe@gmail.com>
+Date: Tue, 10 May 2022 22:47:15 -0400
+Subject: [PATCH] =?UTF-8?q?Fixed=20error:=20=E2=80=98drawAxis=E2=80=99=20i?=
+ =?UTF-8?q?s=20not=20a=20member=20of=20=E2=80=98cv::aruco=E2=80=99=20(open?=
+ =?UTF-8?q?cv=204.5.5)?=
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+---
+ corelib/src/MarkerDetector.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/corelib/src/MarkerDetector.cpp b/corelib/src/MarkerDetector.cpp
+index b59cb9468..2a3957f90 100644
+--- a/corelib/src/MarkerDetector.cpp
++++ b/corelib/src/MarkerDetector.cpp
+@@ -304,7 +304,11 @@ std::map<int, MarkerInfo> MarkerDetector::detect(const cv::Mat & image,
+ std::map<int, MarkerInfo>::iterator iter = detections.find(ids[i]);
+ if(iter!=detections.end())
+ {
++#if CV_MAJOR_VERSION > 4 || (CV_MAJOR_VERSION == 4 && (CV_MINOR_VERSION >1 || (CV_MINOR_VERSION==1 && CV_PATCH_VERSION>=1)))
++ cv::drawFrameAxes(*imageWithDetections, model.K(), model.D(), rvecs[i], tvecs[i], iter->second.length() * 0.5f);
++#else
+ cv::aruco::drawAxis(*imageWithDetections, model.K(), model.D(), rvecs[i], tvecs[i], iter->second.length() * 0.5f);
++#endif
+ }
+ }
+ }
diff --git a/sci-libs/rtabmap/rtabmap-0.20.18.ebuild b/sci-libs/rtabmap/rtabmap-0.20.18.ebuild
new file mode 100644
index 000000000000..61f45ae6ab9f
--- /dev/null
+++ b/sci-libs/rtabmap/rtabmap-0.20.18.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/introlab/rtabmap"
+fi
+
+inherit ${SCM} cmake multilib
+
+VER_SUFFIX=rolling
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/introlab/rtabmap/archive/${PV}-${VER_SUFFIX}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P}-${VER_SUFFIX}"
+fi
+
+DESCRIPTION="Real-Time Appearance-Based Mapping (RGB-D Graph SLAM)"
+HOMEPAGE="http://introlab.github.io/rtabmap/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples ieee1394 openni2 qt5"
+
+RDEPEND="
+ media-libs/opencv:=[qt5(-)?]
+ sci-libs/pcl:=[openni,vtk,qt5(-)?]
+ sci-libs/vtk:=[qt5(-)?]
+ sys-libs/zlib
+ sci-libs/octomap:=
+ dev-libs/boost:=
+ dev-cpp/yaml-cpp:=
+ ieee1394? ( media-libs/libdc1394:2= )
+ openni2? ( dev-libs/OpenNI2 )
+ qt5? (
+ dev-qt/qtwidgets:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/yamlcpp.patch" "${FILESDIR}/ocv.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ "-DWITH_QT=$(usex qt5 ON OFF)"
+ "-DWITH_DC1394=$(usex ieee1394 ON OFF)"
+ "-DWITH_OPENNI2=$(usex openni2 ON OFF)"
+ "-DBUILD_EXAMPLES=$(usex examples ON OFF)"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ # Needed since we force ros crawling to be done only in
+ # /usr/share/ros_packages/
+ insinto /usr/share/ros_packages/${PN}
+ doins "${ED}/usr/share/${PN}/package.xml"
+}