summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-30 15:27:05 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-30 15:27:46 +0100
commita92a0618f69b79728649c1a64a7ee40dc05c665f (patch)
tree5ba69afe21a0d2723405727b39bd9c73a3322dc4
parentnet-analyzer/angst: CFLAGS=-fcommon EAPI=7 IUSE=debug (diff)
downloadgentoo-a92a0618f69b79728649c1a64a7ee40dc05c665f.tar.gz
gentoo-a92a0618f69b79728649c1a64a7ee40dc05c665f.tar.bz2
gentoo-a92a0618f69b79728649c1a64a7ee40dc05c665f.zip
net-analyzer/webfuzzer: Fix CFLAGS=-fno-common
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=707242 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-analyzer/webfuzzer/files/webfuzzer-0.2.0-flags.patch24
-rw-r--r--net-analyzer/webfuzzer/files/webfuzzer-0.2.0-fno-common.patch37
-rw-r--r--net-analyzer/webfuzzer/webfuzzer-0.2.0-r2.ebuild28
3 files changed, 89 insertions, 0 deletions
diff --git a/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-flags.patch b/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-flags.patch
new file mode 100644
index 000000000000..9c40ecf167f7
--- /dev/null
+++ b/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-flags.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,7 +2,7 @@
+ # Makefile for Webfuzzer (c) gunzip
+ #
+
+-CFLAGS=-g -O3 -Wall -DCOLORS
++CFLAGS+= -Wall -DCOLORS
+ CC=gcc
+ LIBS=-lsocket -lnsl -lresolv
+ MOBJS=util.o getpost.o header.o parseform.o hash.o network.o parselinks.o cookies.o webfuzzer.o
+@@ -13,10 +13,10 @@
+ default: webfuzzer
+
+ webfuzzer: main.c $(MOBJS)
+- $(CC) $(CFLAGS) -o webfuzzer main.c $(MOBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o webfuzzer main.c $(MOBJS)
+
+ sunos: main.c $(MOBJS)
+- $(CC) $(CFLAGS) -o webfuzzer main.c $(MOBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o webfuzzer main.c $(MOBJS) $(LIBS)
+
+ clean:
+ rm -rf *.o webfuzzer core
diff --git a/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-fno-common.patch b/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-fno-common.patch
new file mode 100644
index 000000000000..ca40c4ee4f81
--- /dev/null
+++ b/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-fno-common.patch
@@ -0,0 +1,37 @@
+--- a/webfuzzer.h
++++ b/webfuzzer.h
+@@ -30,11 +30,11 @@
+ /**
+ ** GLOBAL HASHTABLES
+ **/
+-struct node * HTlinks[ HT_SIZE ];
+-struct node * HTforms[ HT_SIZE ];
+-struct node * HTusers[ HT_SIZE ];
+-struct node * HTtools[ HT_SIZE ];
+-struct node * HTcookies[ HT_SIZE ];
++extern struct node * HTlinks[ HT_SIZE ];
++extern struct node * HTforms[ HT_SIZE ];
++extern struct node * HTusers[ HT_SIZE ];
++extern struct node * HTtools[ HT_SIZE ];
++extern struct node * HTcookies[ HT_SIZE ];
+
+ #define VERSION "0.2.0"
+ #define BANNER GREEN "Webfuzzer " DEF VERSION " (c) gunzip"
+--- a/webfuzzer.c
++++ b/webfuzzer.c
+@@ -29,6 +29,15 @@
+ #include "technic.h"
+
+ /**
++ ** GLOBAL HASHTABLES
++ **/
++struct node * HTlinks[ HT_SIZE ];
++struct node * HTforms[ HT_SIZE ];
++struct node * HTusers[ HT_SIZE ];
++struct node * HTtools[ HT_SIZE ];
++struct node * HTcookies[ HT_SIZE ];
++
++/**
+ ** PROTOTYPES
+ **/
+
diff --git a/net-analyzer/webfuzzer/webfuzzer-0.2.0-r2.ebuild b/net-analyzer/webfuzzer/webfuzzer-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..66622a2b52db
--- /dev/null
+++ b/net-analyzer/webfuzzer/webfuzzer-0.2.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Poor man's web vulnerability scanner"
+HOMEPAGE="http://gunzip.altervista.org/g.php?f=projects"
+SRC_URI="http://gunzip.altervista.org/webfuzzer/webfuzzer-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/devel
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dodoc CHANGES README TODO
+ dobin webfuzzer
+}