summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-25 13:29:39 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-29 10:34:28 +0100
commita92e53d2923268caf60d6f0991fde4050ceb4539 (patch)
tree52d678b94ad9fa1023d743daca24679895b8383b
parentwww-apps/hugo: drop 0.107.0 (diff)
downloadgentoo-a92e53d2.tar.gz
gentoo-a92e53d2.tar.bz2
gentoo-a92e53d2.zip
dev-python/gentoo-common: Add a new package (v0) for common files
Add a new package to keep the common EXTERNALLY-MANAGED file shared between implementations. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/gentoo-common/gentoo-common-0.ebuild30
-rw-r--r--dev-python/gentoo-common/metadata.xml8
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/gentoo-common/gentoo-common-0.ebuild b/dev-python/gentoo-common/gentoo-common-0.ebuild
new file mode 100644
index 000000000000..58e23e58f72d
--- /dev/null
+++ b/dev-python/gentoo-common/gentoo-common-0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Common files shared by Python implementations in Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python"
+S=${WORKDIR}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+src_install() {
+ insinto /usr/lib/python
+ # https://peps.python.org/pep-0668/
+ newins - EXTERNALLY-MANAGED <<-EOF
+ [externally-managed]
+ Error=
+ The system-wide Python installation in Gentoo should be maintained
+ using the system package manager (e.g. emerge).
+
+ If the package in question is not packaged for Gentoo, please
+ consider installing it inside a virtual environment, e.g.:
+
+ python -m venv /path/to/venv
+ . /path/to/venv/bin/activate
+ pip install mypackage
+ EOF
+}
diff --git a/dev-python/gentoo-common/metadata.xml b/dev-python/gentoo-common/metadata.xml
new file mode 100644
index 000000000000..7d421671d884
--- /dev/null
+++ b/dev-python/gentoo-common/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+</pkgmetadata>