summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-12 09:04:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-12 09:05:54 +0200
commita9764cd38fe412fcf973f159c858a9cc16a8e2b8 (patch)
tree28f911ead65b08725e62007a61ab891a8d77420b
parentdev-python/cython: Backport fix for `metaclass=EnumMeta` (diff)
downloadgentoo-a9764cd38fe412fcf973f159c858a9cc16a8e2b8.tar.gz
gentoo-a9764cd38fe412fcf973f159c858a9cc16a8e2b8.tar.bz2
gentoo-a9764cd38fe412fcf973f159c858a9cc16a8e2b8.zip
dev-python/gssapi: Allow patched cython-3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/gssapi/gssapi-1.8.3-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/gssapi/gssapi-1.8.3-r1.ebuild b/dev-python/gssapi/gssapi-1.8.3-r1.ebuild
new file mode 100644
index 000000000000..d666e9ace6d9
--- /dev/null
+++ b/dev-python/gssapi/gssapi-1.8.3-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low and high level wrappers around the GSSAPI C libraries"
+HOMEPAGE="
+ https://github.com/pythongssapi/python-gssapi/
+ https://pypi.org/project/gssapi/
+"
+SRC_URI="
+ https://github.com/pythongssapi/python-gssapi/releases/download/v${PV}/python-${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}"/python-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ virtual/krb5
+"
+
+BDEPEND="
+ || (
+ >=dev-python/cython-3.0.2-r1[${PYTHON_USEDEP}]
+ <dev-python/cython-3[${PYTHON_USEDEP}]
+ )
+ virtual/krb5
+ test? (
+ dev-python/k5test[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gssapi
+}