summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2018-10-23 17:53:08 -0400
committerMichał Górny <mgorny@gentoo.org>2018-11-02 22:14:28 +0100
commita97d44c1e172e9eba95dbc9edb294e2087405b39 (patch)
treeccefb36c03f7ce0c5abf3c0bbb8c95aad0c73930
parentdev-lang/go: remove 1.9 (diff)
downloadgentoo-a97d44c1.tar.gz
gentoo-a97d44c1.tar.bz2
gentoo-a97d44c1.zip
dev-python/neovim-remote: version bump to 2.1.0
Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/neovim-remote/Manifest1
-rw-r--r--dev-python/neovim-remote/neovim-remote-2.1.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/neovim-remote/Manifest b/dev-python/neovim-remote/Manifest
index c8fb9c3ed20b..02a199db8a39 100644
--- a/dev-python/neovim-remote/Manifest
+++ b/dev-python/neovim-remote/Manifest
@@ -1 +1,2 @@
DIST neovim-remote-1.8.6.tar.gz 434012 BLAKE2B 1fddb5e4376d3d17c2ff0c00e5f98700ab2d221af1ed1bc3f9c6dabe9cf1bdafe9f85041cb3a01f9a45f03df2d76bc0ae3c5a93603caa9ad461eb5ae50cb832f SHA512 b973b8c495a3a371b9a21ec4110beebbfe304f00d73aaf1da849df612e6ea9a08258379600ccb8d83154b8ef12e26088ba90a1668c5262b7dc9c62c844f42798
+DIST neovim-remote-2.1.0.tar.gz 437657 BLAKE2B 056bcc1edff5225b478e72f0b0ce3b8f296ed49d9d8a035bce88b6d26daeda884640f9f6a50b68d91a8ad38a4980f554385e799302a541ce2d6985110357188d SHA512 23f6e98d57d856477b51c77aaa417af8a7a9aa02821f4dbd4870af7b3f9de07c4ba46ceae036ddb17382de4829238114dafa4b2b6d1e6dc71f1d9b4ba935b562
diff --git a/dev-python/neovim-remote/neovim-remote-2.1.0.ebuild b/dev-python/neovim-remote/neovim-remote-2.1.0.ebuild
new file mode 100644
index 000000000000..d77fc60b85e8
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-2.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="https://github.com/mhinz/neovim-remote"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/neovim-python-client[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ pytest -vv || die
+}