summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2023-12-03 13:21:45 -0800
committerJohn Helmert III <ajak@gentoo.org>2023-12-03 13:41:07 -0800
commita9afdf51cd1af93791ee5f5bcc47b95834b076f0 (patch)
tree7e2b64616711884355c487bdd34b2fd2c1c24d48
parentapp-admin/gopass-hibp: add 1.15.11 (diff)
downloadgentoo-a9afdf51cd1af93791ee5f5bcc47b95834b076f0.tar.gz
gentoo-a9afdf51cd1af93791ee5f5bcc47b95834b076f0.tar.bz2
gentoo-a9afdf51cd1af93791ee5f5bcc47b95834b076f0.zip
app-admin/gopass-jsonapi: add 1.15.11
Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--app-admin/gopass-jsonapi/Manifest2
-rw-r--r--app-admin/gopass-jsonapi/gopass-jsonapi-1.15.11.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/app-admin/gopass-jsonapi/Manifest b/app-admin/gopass-jsonapi/Manifest
index e0c9fb085869..53e552150344 100644
--- a/app-admin/gopass-jsonapi/Manifest
+++ b/app-admin/gopass-jsonapi/Manifest
@@ -1,5 +1,7 @@
DIST gopass-jsonapi-1.15.10-deps.tar.xz 288522312 BLAKE2B 1b13ebb6b0ec4cef6681aeb7e3d2c9ca88abea3c57d476b01b8b2ec1e2b040646bcf48b03c24974d78f0c79da8ef3cdcbe2406dc09506cae627ff1c3bb9b9ebb SHA512 3ae5ca8ab37821ed1a03475ddac558ef7c5710e988c006eaa42d87e0bd35d9cfb944c1819ba610ea46daeb0a6523c4a9e439d287af6aba3cd5c1dfa5143692fc
DIST gopass-jsonapi-1.15.10.tar.gz 35998 BLAKE2B 79a2151628559af3c7505e177dd39bb42d51644bfbf7984baa3ed2dd812bb048cdbc5ca1ee695aa1257de1c3f4a7d0ef4e4c75cbdb8e2147897e7ae17290effb SHA512 2d9bfaddfd7ca0741d9028ef8641732285e0c5be611e5cb1065f4bd205623b86066e812dd6204199b50bc4aa1528cdca42e149130cdeed9c31e0a32b6724c2d9
+DIST gopass-jsonapi-1.15.11-deps.tar.xz 288583480 BLAKE2B f914d07a5b00f82bb1baa3114736fdde720a8bfb4b2378c60015501c281a14b595fff96c40b06c0f9f8d867e5b2004a43aa9eed4e3cf4016bdfb2a8acb221a78 SHA512 220f31aae7db0a268b4658f1464c8b1256958f2d220ebc028701db1ab2eda998b92d493e0facf741fc4d83135cf53d3fda5ac24f84365cd567da3d825623b0f6
+DIST gopass-jsonapi-1.15.11.tar.gz 36121 BLAKE2B cc9832c9473d1ed0095ff10f6fbbe763d0b4a3a76fb891089f75a0cd0eb677e1c1c87598ff8beb1494d5790870c39d78df0c52ce9be68a127e0d8d725a9dcdc0 SHA512 7231edc6bf6a529761a193fda40fdf254ffdaab6853d9a265d4d7ff3fcdc08fb418f9c4f1a05f32180eccde5add1a5276fa01133fc90a61c57c4c9793a9abc3a
DIST gopass-jsonapi-1.15.8-deps.tar.xz 286568008 BLAKE2B 711b652fb6fa50cb6654343177f9b13f53f230bab9e1f6754ff2daaad114925581ac856e1986eb59f317881ceb8e84ad1e32390ede847cbb95f572293912771b SHA512 9d65bc216a14380bb519c5259bcf296494ff44f4d6bbe97b6561bef5e7c863e2130497386b74055f9a34dc9f1367d7f8afcee48eb8b8a667ba200e1af94daa7f
DIST gopass-jsonapi-1.15.8.tar.gz 35780 BLAKE2B f478fed2d85bcd098d6635d9180d7200f3a0cf7ea106db3cb6b71cda0b9ed45a9bf68ac3fe69de67d025fc9007eed9b1d4c607c4a8ff0630bbf01ec963b12b19 SHA512 6433fb5888e31f6d24db633b8d33c773537da781614bf7fe231dc364a20a27ea1170c5d938b1ccdfcad246032a9aa06e2ab960cad05522c4146aa0507b1f750c
DIST gopass-jsonapi-1.15.9-deps.tar.xz 288658032 BLAKE2B 79bfb69623a300848eabc0571a8e82cf6a241c99ea647cac758a0f17ec7bff2bff5f91a837f2f8a72955f16d76d6f7b9f8a31e54f450f8307af506e364dde97b SHA512 74e091a06682ee2aacfa770e7482ea1ea1eb337e7ff0e9cca86256a23bc80640772efd42061e9e94076d9e7609955155a1628e07a090e76d05dfa0c34f532acb
diff --git a/app-admin/gopass-jsonapi/gopass-jsonapi-1.15.11.ebuild b/app-admin/gopass-jsonapi/gopass-jsonapi-1.15.11.ebuild
new file mode 100644
index 000000000000..87a6430f0e13
--- /dev/null
+++ b/app-admin/gopass-jsonapi/gopass-jsonapi-1.15.11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Gopass Browser Bindings"
+HOMEPAGE="https://github.com/gopasspw/gopass-jsonapi"
+SRC_URI="https://github.com/gopasspw/gopass-jsonapi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~ajak/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD MPL-2.0 BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=">=dev-lang/go-1.16"
+RDEPEND="
+ dev-vcs/git
+ >=app-crypt/gnupg-2
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.15.3-skip-test.patch"
+)