summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-11-15 19:59:45 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-11-15 19:59:45 +0100
commita9b4caa8adfc3b3c60b8c3ff74dc9e1d8a40b898 (patch)
treeffb88ece0b21083355e22dd3e836016de1aad7e0
parentapp-misc/ca-certificates: Bump to version 20170717.3.34 (diff)
downloadgentoo-a9b4caa8.tar.gz
gentoo-a9b4caa8.tar.bz2
gentoo-a9b4caa8.zip
media-libs/harfbuzz: Bump to version 1.7.1
Package-Manager: Portage-2.3.14, Repoman-2.3.6
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-1.7.1.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index 5e7cc5f9e4f1..2e6352f4b67e 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -4,3 +4,4 @@ DIST harfbuzz-1.4.8.tar.bz2 1587622 SHA256 ccec4930ff0bb2d0c40aee203075447954b64
DIST harfbuzz-1.5.1.tar.bz2 1615704 SHA256 56838dfdad2729b8866763c82d623354d138a4d99d9ffb710c7d377b5cfc7c51 SHA512 e5235c9fe4524059128f97e2773056533803b40db70c18b43c8dc6e27a970efc40d9ce6e8754ae7075c245cf8f4386b33e922a6edb3b6a722a596cb7759b8b36 WHIRLPOOL 8cf092ffcf42b5744041b3e2d40ce720a2a089964bb5d8d6a3ed5ccb846df8f3f44e6182744cb7b8c132e2fbfcc93c13fd974c2faa0adcf66961fc3b9863563d
DIST harfbuzz-1.6.2.tar.bz2 1639114 SHA256 ceb8cbd652829b5fa680a71d89cb79cac7afa104e9484fbd23a24e71c0d6e80e SHA512 90fd16267b19dfcb9fba0553555405df46b7543f48476bea3d9f59bdc809c8257f05bd0436ab32a3582a3f8dbef7448ba10485699d1435b56d8c247e2fcfeff3 WHIRLPOOL 8081a1d82d82b95f47162834ceb05134a1ddeb6aefb1d81c9483bba1440e4e146e92d9fd205ab63c54c6b36d0097b0ad19a966ea184e6ef6bfe35426d6899db8
DIST harfbuzz-1.6.3.tar.bz2 1643142 SHA256 e31eb367beb61a9399d2c78b51c225ab2b1cbd46f364f2d80d97bb422b44101a SHA512 37d1a161d9074e9898d9ef6cca6dffffc725005828d700744553b0145373b69bcd3b08f507d49f4c2e05850d9275a54f15983356c547c86e5e3c202cc7cbfbe8 WHIRLPOOL 60da1d7c30e08704d8eed14b9b5f7fb4d68915627dece5a9802f5cc46309ea15e250f351d8e273f2710dbac93d3f7b7574ebd9c167446b6195c7a74f458e952b
+DIST harfbuzz-1.7.1.tar.bz2 1662385 SHA256 9645a6e83313b690602017f18d4eb2adf81f2e54c6fc4471e19331304965154e SHA512 e78c96a4debfc4761075aca50de111acf394bb966c038b8cebc26fd01a113d53492946709cf54dcc30d87bb6b5d920509181b5a0fc9ea0a010a399e94ad090b7 WHIRLPOOL 5cabbf0a274341cac7b6f174493eaff12aa0b250551723608ede22a28b3e550142a8f485e1c63f14d57241f8aa4060fd3ef6d385210a61ff664ce179608f7baf
diff --git a/media-libs/harfbuzz/harfbuzz-1.7.1.ebuild b/media-libs/harfbuzz/harfbuzz-1.7.1.ebuild
new file mode 100644
index 000000000000..da388e5fba70
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-1.7.1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz"
+[[ ${PV} == 9999 ]] && inherit git-r3 autotools
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils flag-o-matic libtool multilib-minimal python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+[[ ${PV} == 9999 ]] || SRC_URI="https://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+
+IUSE="+cairo debug fontconfig +glib +graphite icu +introspection static-libs test +truetype"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ fontconfig? ( media-libs/fontconfig:1.0[${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
+"
+# eautoreconf requires gobject-introspection-common
+# ragel needed if regenerating *.hh files from *.rl
+[[ ${PV} = 9999 ]] && DEPEND="${DEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+ dev-util/ragel
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+ if ! use debug ; then
+ append-cppflags -DHB_NDEBUG
+ fi
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
+ # on Darwin/Solaris we need to link with g++, like automake defaults
+ # to, but overridden by upstream because on Linux this is not
+ # necessary, bug #449126
+ sed -i \
+ -e 's/\<LINK\>/CXXLINK/' \
+ src/Makefile.am || die
+ sed -i \
+ -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
+ src/Makefile.in || die
+ sed -i \
+ -e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
+ test/api/Makefile.in || die
+ fi
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+ elibtoolize # for Solaris
+
+ # failing test, https://bugs.freedesktop.org/show_bug.cgi?id=89190
+ sed -e 's#tests/arabic-fallback-shaping.tests##' -i test/shaping/Makefile.in || die "sed failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ # harfbuzz-gobject only used for instrospection, bug #535852
+ econf \
+ --without-coretext \
+ --without-uniscribe \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_with cairo) \
+ $(use_with fontconfig) \
+ $(use_with glib) \
+ $(use_with introspection gobject) \
+ $(use_with graphite graphite2) \
+ $(use_with icu) \
+ $(multilib_native_use_enable introspection) \
+ $(use_with truetype freetype)
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/html docs/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}