summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-06-30 10:40:34 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-30 15:30:58 +0200
commita9c6dc1ae3be00280577ba3a8f402c6305294a8a (patch)
tree8cf73ced58897d92be78f5fd0998b69d64193c61
parentsys-cluster/glusterfs: drop old (diff)
downloadgentoo-a9c6dc1a.tar.gz
gentoo-a9c6dc1a.tar.bz2
gentoo-a9c6dc1a.zip
sys-cluster/glusterfs: sync live ebuild
Package-Manager: Portage-2.3.102, Repoman-2.3.23 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16502 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--sys-cluster/glusterfs/glusterfs-9999.ebuild64
-rw-r--r--sys-cluster/glusterfs/metadata.xml6
2 files changed, 24 insertions, 46 deletions
diff --git a/sys-cluster/glusterfs/glusterfs-9999.ebuild b/sys-cluster/glusterfs/glusterfs-9999.ebuild
index 544b9e693be5..718ab4740bc1 100644
--- a/sys-cluster/glusterfs/glusterfs-9999.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-9999.ebuild
@@ -3,15 +3,15 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6..9} )
-inherit autotools elisp-common python-single-r1 systemd user
+inherit autotools elisp-common python-single-r1 systemd
if [[ ${PV#9999} != ${PV} ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/gluster/glusterfs.git"
else
- SRC_URI="https://download.gluster.org/pub/gluster/${PN}/$(ver_cut '1-2')/${PV}/${P}.tar.gz"
+ SRC_URI="https://download.gluster.org/pub/gluster/${PN}/$(ver_cut 1)/${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
fi
@@ -20,40 +20,39 @@ HOMEPAGE="https://www.gluster.org/"
LICENSE="|| ( GPL-2 LGPL-3+ )"
SLOT="0"
-IUSE="bd-xlator crypt-xlator debug emacs +fuse +georeplication glupy infiniband ipv6 libressl +libtirpc qemu-block rsyslog static-libs +syslog systemtap test +tiering vim-syntax +xml"
+IUSE="debug emacs +fuse +georeplication infiniband ipv6 libressl +libtirpc rsyslog static-libs +syslog test vim-syntax +xml"
REQUIRED_USE="georeplication? ( ${PYTHON_REQUIRED_USE} )
- glupy? ( ${PYTHON_REQUIRED_USE} )
ipv6? ( libtirpc )"
# the tests must be run as root
RESTRICT="test"
# sys-apps/util-linux is required for libuuid
-RDEPEND="bd-xlator? ( sys-fs/lvm2 )
- !elibc_glibc? ( sys-libs/argp-standalone )
+RDEPEND="
+ acct-group/gluster
+ acct-user/gluster
+ dev-libs/libaio
+ dev-libs/userspace-rcu:=
+ net-libs/rpcsvc-proto
+ sys-apps/util-linux
+ sys-libs/readline:=
emacs? ( >=app-editors/emacs-23.1:* )
fuse? ( >=sys-fs/fuse-2.7.0:0 )
georeplication? ( ${PYTHON_DEPS} )
infiniband? ( sys-fabric/libibverbs:* sys-fabric/librdmacm:* )
+ xml? ( dev-libs/libxml2 )
+ !elibc_glibc? ( sys-libs/argp-standalone )
libtirpc? ( net-libs/libtirpc:= )
!libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
- qemu-block? ( dev-libs/glib:2 )
- systemtap? ( dev-util/systemtap )
- tiering? ( dev-db/sqlite:3 )
- xml? ( dev-libs/libxml2 )
- sys-libs/readline:=
- dev-libs/libaio
!libressl? ( dev-libs/openssl:=[-bindist] )
libressl? ( dev-libs/libressl:= )
- dev-libs/userspace-rcu:=
- net-libs/rpcsvc-proto
- sys-apps/util-linux"
-DEPEND="${RDEPEND}
- virtual/acl
- virtual/pkgconfig
+"
+DEPEND="
+ ${RDEPEND}
sys-devel/bison
sys-devel/flex
+ virtual/acl
test? ( >=dev-util/cmocka-1.0.1
app-benchmarks/dbench
dev-vcs/git
@@ -61,15 +60,14 @@ DEPEND="${RDEPEND}
virtual/perl-Test-Harness
dev-libs/yajl
sys-fs/xfsprogs
- sys-apps/attr )"
+ sys-apps/attr )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
SITEFILE="50${PN}-mode-gentoo.el"
-PATCHES=(
- "${FILESDIR}/${PN}-3.12.2-poisoned-sysmacros.patch"
- "${FILESDIR}/${PN}-4.1.0-silent_rules.patch"
-)
-
DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
# Maintainer notes:
@@ -78,13 +76,8 @@ DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
# glibc or if argp-standalone is installed.
pkg_setup() {
- python_setup "python2*"
+ python_setup "python3*"
python-single-r1_pkg_setup
-
- # Needed for statedumps
- # https://github.com/gluster/glusterfs/commit/0e50c4b3ea734456c14e2d7a578463999bd332c3
- enewgroup gluster
- enewuser gluster -1 -1 "${EPREFIX}"/var/run/gluster gluster
}
src_prepare() {
@@ -104,18 +97,12 @@ src_configure() {
econf \
--disable-fusermount \
$(use_enable debug) \
- $(use_enable bd-xlator) \
- $(use_enable crypt-xlator) \
$(use_enable fuse fuse-client) \
$(use_enable georeplication) \
- $(use_enable glupy) \
$(use_enable infiniband ibverbs) \
- $(use_enable qemu-block) \
$(use_enable static-libs static) \
$(use_enable syslog) \
- $(use_enable systemtap) \
$(use_enable test cmocka) \
- $(use_enable tiering) \
$(use_enable xml xml-output) \
$(use libtirpc || echo --without-libtirpc) \
$(use ipv6 && echo --with-ipv6-default) \
@@ -184,9 +171,6 @@ src_install() {
if ! use static-libs; then
find "${D}" -type f -name '*.la' -delete || die
fi
-
- # fix all shebang for python2 #560750
- python_fix_shebang "${ED}"
}
src_test() {
diff --git a/sys-cluster/glusterfs/metadata.xml b/sys-cluster/glusterfs/metadata.xml
index ce2361e3e3ea..a521dcb91e64 100644
--- a/sys-cluster/glusterfs/metadata.xml
+++ b/sys-cluster/glusterfs/metadata.xml
@@ -9,18 +9,12 @@
GlusterFS is a cluster file-system capable of scaling to several peta-bytes. It aggregates various storage bricks over Infiniband RDMA or TCP/IP interconnect into one large parallel network file system. GlusterFS is based on a stackable user space design without compromising performance.
</longdescription>
<use>
- <flag name="bd-xlator">Enable the blockdevice translator (requires <pkg>sys-fs/lvm2</pkg>)</flag>
- <flag name="crypt-xlator">Enable the encryption translator</flag>
<flag name="fuse">Add FUSE mount helper</flag>
- <flag name="glupy">Enable support for translators written in Python</flag>
<flag name="georeplication">Enable support for georeplication (requires <pkg>dev-lang/python</pkg>)</flag>
<flag name="infiniband">Add support for Infiniband ibverbs transport.
Libraries can be found in science overlay</flag>
<flag name="ipv6">Use IPv6 by default, requires libtirpc</flag>
<flag name="libtirpc">Build against <pkg>net-libs/libtirpc</pkg> for RPC support</flag>
<flag name="rsyslog">Install configuration snippet for <pkg>app-admin/rsyslog</pkg></flag>
- <flag name="qemu-block">Transparently create files as QCow2/QED images in the backend, including the possibility to snapshot.</flag>
- <flag name="systemtap">Enable support for <pkg>dev-util/systemtap</pkg></flag>
- <flag name="tiering">Enable support for data classification/tiering (requires <pkg>dev-db/sqlite</pkg> SLOT 3)</flag>
</use>
</pkgmetadata>