summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 08:42:17 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 08:48:44 +0100
commita9e8a8a541511c1d6d20601c3051e902ffa956ef (patch)
treea78cc69a0c6a2f9eaf30fa665746b97118201666
parentdev-python/diskcache: Migrate to PEP517 build (diff)
downloadgentoo-a9e8a8a5.tar.gz
gentoo-a9e8a8a5.tar.bz2
gentoo-a9e8a8a5.zip
dev-python/unicodecsv: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/unicodecsv/unicodecsv-0.14.1-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/unicodecsv/unicodecsv-0.14.1-r2.ebuild b/dev-python/unicodecsv/unicodecsv-0.14.1-r2.ebuild
new file mode 100644
index 000000000000..7b08a0159317
--- /dev/null
+++ b/dev-python/unicodecsv/unicodecsv-0.14.1-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for python stdlib csv module supporting unicode"
+HOMEPAGE="
+ https://pypi.org/project/unicodecsv/
+ https://github.com/jdunck/python-unicodecsv/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # un-depend on unittest2
+ sed -i -e 's:unittest2 as ::' unicodecsv/test.py || die
+ distutils-r1_src_prepare
+}