summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-02 08:42:04 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-02 09:50:37 +0200
commitaa029f025da27bb3fa6f11b6695697be08fcf43e (patch)
treef8d780234ae065421857a2155f500d00ac77a5fe
parentapp-admin/awscli: Bump to 1.20.53 (diff)
downloadgentoo-aa029f02.tar.gz
gentoo-aa029f02.tar.bz2
gentoo-aa029f02.zip
dev-python/qrcode: Bump to 7.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/qrcode/Manifest1
-rw-r--r--dev-python/qrcode/qrcode-7.3.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/qrcode/Manifest b/dev-python/qrcode/Manifest
index 9bab5d4f769b..a090d59738e4 100644
--- a/dev-python/qrcode/Manifest
+++ b/dev-python/qrcode/Manifest
@@ -1 +1,2 @@
+DIST qrcode-7.3.1.tar.gz 43495 BLAKE2B 9986ee77752625e127008038c6c044b5adeb3bd526c27a55b23915190c3c9069adf1c6df1ce5f76cd0255f45319ecb66ebf226932666ea6c89872a46e13c1cd9 SHA512 9e0e508418164926a074d8c6d85419b39a36c01ac6d92415a15ce43d4aea79fa2a8d0167982f832970d2a68ec18d2b729f09e15d80b4f4c33b992999527d39f9
DIST qrcode-7.3.tar.gz 43352 BLAKE2B 4520ffcf2c4b144c20d00d06947c65ac9d8eb283ab9e298d9fe1de023aa32e47e3c6d4d9144f928a12607b28415f40d666b68b920d81e18524c95813768ee2d7 SHA512 e4d06ace4e8146e294b10b1397e649cc56405ddac35dae499bf897e4a7eb37b15dee3f72e6a7bac98dd0f238ac71d1e0bab5ada6cd180b1e5e8df9c6cb23f073
diff --git a/dev-python/qrcode/qrcode-7.3.1.ebuild b/dev-python/qrcode/qrcode-7.3.1.ebuild
new file mode 100644
index 000000000000..0185db078736
--- /dev/null
+++ b/dev-python/qrcode/qrcode-7.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="QR Code generator on top of PIL"
+HOMEPAGE="https://pypi.org/project/qrcode/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+# optional deps:
+# - pillow and lxml for svg backend, set as hard deps
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/qr.1
+}