summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-16 01:10:15 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-16 01:20:22 +0200
commitaa0c5d3b22c2eb9bb7ae42d9295babae823f91b5 (patch)
tree05a443f3f7283167364c88a5e5eaf2e2e2669c74
parentapp-crypt/certbot-dns-nsone: mark ALLARCHES (diff)
downloadgentoo-aa0c5d3b22c2eb9bb7ae42d9295babae823f91b5.tar.gz
gentoo-aa0c5d3b22c2eb9bb7ae42d9295babae823f91b5.tar.bz2
gentoo-aa0c5d3b22c2eb9bb7ae42d9295babae823f91b5.zip
app-crypt/certbot-dns-nsone: add 1.18.0, enable py3.10, tests and doc
Closes: https://bugs.gentoo.org/795543 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--app-crypt/certbot-dns-nsone/Manifest1
-rw-r--r--app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/certbot-dns-nsone/Manifest b/app-crypt/certbot-dns-nsone/Manifest
index 825236135af9..59c172d8f564 100644
--- a/app-crypt/certbot-dns-nsone/Manifest
+++ b/app-crypt/certbot-dns-nsone/Manifest
@@ -1 +1,2 @@
DIST certbot-dns-nsone-0.39.0.tar.gz 1350312 BLAKE2B 5f21c45d25754cb1ed0ad92e8d03637928a274637de09903509c7e78c40fd197e95cfa1f3effecef938d6ab8369dc6811714ddb5a93a806048e0998d1032e4f9 SHA512 17ab17a5f74e3fba58b1a8b9afe0c3656c7b2a5ea3585edb05ad84e36250c6a8d4d28bd692bc97d033c95eb0bbeff4eb84981ae0006e36d55846cd38373b86a0
+DIST certbot-dns-nsone-1.18.0.tar.gz 1332615 BLAKE2B eb086710b943893025d6e1091470ca02de074232372f4c9fa21fa83a347fe54df988b9553c8cf6afd6e166b8c464d595171984c984008a872e16c0179bb774b2 SHA512 94b16ba0586e0f5d3036280c68f9976c25889ca48fbbe7aded41f0d9feba2300a3f0ff8fe321b39d8642bcdd874c7332cf2acb3187b5869fe415831f58a75a7b
diff --git a/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild
new file mode 100644
index 000000000000..1fea8e6f659c
--- /dev/null
+++ b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+S=${WORKDIR}/certbot-${PV}/${PN}
+
+inherit distutils-r1
+
+DESCRIPTION="NS1 DNS Authenticator plugin for Certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ >=dev-python/dns-lexicon-3.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest