summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-05-10 23:09:13 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-05-10 23:09:27 +0100
commitaa35a17bd1114859c109384a81bf1b6c773a6253 (patch)
tree5d40c4889e6ac17fc3a1ba98f1b07e5c80b7b48b
parentmedia-sound/mixxx: Added live ebuild. (diff)
downloadgentoo-aa35a17b.tar.gz
gentoo-aa35a17b.tar.bz2
gentoo-aa35a17b.zip
dev-lang/nasm: switch to media-fonts/source-pro fonts
nasm has an ordered list of font preference. media-fonts/clearsans alone is not enough to satisfy all nasm needs (see doc/psfonts.ph). Use media-fonts/source-pro instead. This also happens to fix font width in final generated .pdf. Reported-by: Juergen Rose Closes: https://bugs.gentoo.org/639038 Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--dev-lang/nasm/nasm-2.13.03-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-lang/nasm/nasm-2.13.03-r1.ebuild b/dev-lang/nasm/nasm-2.13.03-r1.ebuild
new file mode 100644
index 000000000000..c0c02a3bcd11
--- /dev/null
+++ b/dev-lang/nasm/nasm-2.13.03-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="groovy little assembler"
+HOMEPAGE="http://www.nasm.us/"
+SRC_URI="http://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc"
+
+# [fonts note] doc/psfonts.ph defines ordered list of font preference.
+# Currently 'media-fonts/source-pro' is most preferred and is able to
+# satisfy all 6 font flavours: tilt, chapter, head, etc.
+DEPEND="
+ dev-lang/perl
+ doc? (
+ app-text/ghostscript-gpl
+ dev-perl/Font-TTF
+ dev-perl/Sort-Versions
+ media-fonts/source-pro
+ virtual/perl-File-Spec
+ )
+"
+
+S=${WORKDIR}/${P/_}
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.13.01-fix-docdir.patch
+ "${FILESDIR}"/${PN}-2.13.01-gcc-8.patch
+)
+
+src_configure() {
+ strip-flags
+ default
+}
+
+src_compile() {
+ default
+ use doc && emake doc
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install_rdf $(usex doc install_doc '')
+}