summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-02 09:00:44 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-02 11:59:18 +0100
commitaa6323fd4d24378a1485b1eb81fbcf19739a7b1b (patch)
tree13f037f15c4b0d1369b39fae0f184c760892e427
parentdev-python/python-utils: Bump to 2.7.1 (diff)
downloadgentoo-aa6323fd.tar.gz
gentoo-aa6323fd.tar.bz2
gentoo-aa6323fd.zip
dev-python/virtualenv: Bump to 20.12.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/virtualenv/Manifest1
-rw-r--r--dev-python/virtualenv/virtualenv-20.12.1.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index 9fdf8d5f7b5d..b8ed7dc14e20 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -2,3 +2,4 @@ DIST virtualenv-20.10.0.tar.gz 9007218 BLAKE2B 1fd37b38679b7375c1eb6e9644418b165
DIST virtualenv-20.11.1.tar.gz 9952979 BLAKE2B d8e44f5a8fedfca4eed79798be74ccfca86af2cacc076d797832028363c2d5269194e711d4511a415420285bc408373a641248a5a96cfaea326f60e023129d65 SHA512 c378bd088d9f2f6a07128d6d04b71554ad7c4de6227baea68ea486c8e10c99c40818eb9bf98cb4c950e64d0aeed4d2be40c101fbd6005d48d2eccaea0382d581
DIST virtualenv-20.11.2.tar.gz 9953645 BLAKE2B 8bd0e5bee4fad2cdb13b1ce3e018191ef69993c9d1c66332c74908483802b2d1aff1ea1ef9acd4d94b17cacc9ae4c4014ded6ac0e7df4ea807d050d1243d5464 SHA512 18f9c6e50aa6d7b7060163b23332d7e9140199e525f7fb4efe99e84dfb298413889f4516b6e942d3e05a667774093ed521cc757a67a1698138cb793b9798a46f
DIST virtualenv-20.12.0.tar.gz 9955140 BLAKE2B 3d01e6b08ce9002310b3659b1773bec850d23bf5bd79d414e8b8a36d7f675cfe5b16f8522758c64911d596a8c1e8994fe126037e38cfe59d42e62d4b9adad8f0 SHA512 235074d6f1edae7f350991d3774eb5b567d5fb53c86d3ec7f86b237fccd71256d0700d7ecaa6a82bc1b7611af743cc1fde2f083c43beadac5f317af69c7d1a14
+DIST virtualenv-20.12.1.tar.gz 9956052 BLAKE2B 1507e45de7d1383062b18a2796baf91befec576200560e3a07a5b78e563d6c93cd8f1b3aea327d2edf4d9e582a9a4a9c62f03e9f8cf023318ea4a6cd1fdc6c79 SHA512 1f1a721f1b03cab72330827bca68741cc7f3d4c713a44eb50028ce7b72101cf7530f12cb1fbbff1c94ce9ce621601484845069f34d0c36250f80d8186b2501f9
diff --git a/dev-python/virtualenv/virtualenv-20.12.1.ebuild b/dev-python/virtualenv/virtualenv-20.12.1.ebuild
new file mode 100644
index 000000000000..2d81da1735a3
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-20.12.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="
+ https://virtualenv.pypa.io/en/stable/
+ https://pypi.org/project/virtualenv/
+ https://github.com/pypa/virtualenv/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/backports-entry_points_selectable-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+# coverage is used somehow magically in virtualenv, maybe it actually
+# tests something useful
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/pip-20.0.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-freezegun-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-1.3.4[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ )"
+
+# (unpackaged deps)
+#distutils_enable_sphinx docs \
+# dev-python/sphinx-argparse \
+# dev-python/sphinx_rtd_theme \
+# dev-python/towncrier
+distutils_enable_tests pytest
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/unit/activation/test_xonsh.py
+ tests/unit/seed/embed/test_bootstrap_link_via_app_data.py::test_seed_link_via_app_data
+ tests/unit/create/test_creator.py::test_cross_major
+ )
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-global]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-global]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-global]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-global]'
+ 'tests/unit/create/test_creator.py::test_zip_importer_can_import_setuptools'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3--bin-]'
+ )
+
+ distutils_install_for_testing
+ epytest
+}
+
+pkg_postinst() {
+ elog "Please note that while virtualenv package no longer supports"
+ elog "Python 2.7, you can still create py2.7 virtualenvs via:"
+ elog " $ virtualenv -p 2.7 ..."
+}