summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2017-05-04 11:45:35 +0300
committerEray Aslan <eras@gentoo.org>2017-05-04 11:46:15 +0300
commitaa6441f4d19651a9dc1f939b1ad36364426adc87 (patch)
tree153926fb6796f36d28cc6e300e6b73d3f249ac79
parentmedia-libs/exiftool: version bump to 10.51 (diff)
downloadgentoo-aa6441f4.tar.gz
gentoo-aa6441f4.tar.bz2
gentoo-aa6441f4.zip
net-mail/gnubiff: version bump to 2.2.17 - bug 616340
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--net-mail/gnubiff/Manifest1
-rw-r--r--net-mail/gnubiff/gnubiff-2.2.17.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-mail/gnubiff/Manifest b/net-mail/gnubiff/Manifest
index cee6a6c5147e..43360c958103 100644
--- a/net-mail/gnubiff/Manifest
+++ b/net-mail/gnubiff/Manifest
@@ -1 +1,2 @@
DIST gnubiff-2.2.15.tar.gz 851638 SHA256 1565af4084f1f6335ab4df412e60bca14591cc2ca35db60d950972b7240f80d9 SHA512 592a9934f34cec65869bef6bb7a488fd1a44515d513e47b440a36ef15ff9c44dbedb33c27e375ac6cc9590d9a0f02b315307913059f3d7e44ee64a87d95f52c4 WHIRLPOOL ac04fdb2aab577cc93df5aeef82ea3a93200728d6fbc0bdd3172dda011aad5507b6b448515dda1b1d855b2074891afb7ac983f5bfafbd6af2d31d7a5d72c8274
+DIST gnubiff-2.2.17.tar.gz 897817 SHA256 e616ab031d493e4b9b27a2bccc810e4b2ada912b3cf8d44f39325cbc5293fb2c SHA512 2fe715d584fb057255d4922275de152ff5b1167abcbdd27d33124921a4c659c3db301944a73d58622ecd22f62615d44b5bebb83838bbd53c67a2dd8286592d89 WHIRLPOOL b0d7b793b3bb3d70479e1701721eee4d5c54014eaa9498c4bb2aaffe398c95ced55ff71f6d700214b0eb4002d053126d14b20758b522b0ec9b7c28d7b6956909
diff --git a/net-mail/gnubiff/gnubiff-2.2.17.ebuild b/net-mail/gnubiff/gnubiff-2.2.17.ebuild
new file mode 100644
index 000000000000..a370cd6f9114
--- /dev/null
+++ b/net-mail/gnubiff/gnubiff-2.2.17.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="A mail notification program"
+HOMEPAGE="http://gnubiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fam nls password"
+
+RDEPEND="
+ >=x11-libs/gtk+-3:3
+ >=gnome-base/libglade-2.3
+ dev-libs/popt
+ password? ( dev-libs/openssl:* )
+ fam? ( virtual/fam )
+ x11-proto/xproto
+ x11-libs/libX11
+ x11-libs/pango
+ x11-libs/gdk-pixbuf
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
+
+src_prepare() {
+ eapply -p0 "${FILESDIR}/${PN}-2.2.15-fix-nls.patch"
+ eapply -p1 "${FILESDIR}/${PN}-2.2.15-gold.patch"
+ eapply -p0 "${FILESDIR}/${PN}-2.2.15-underlink.patch"
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ # note: --disable-gnome is to avoid deprecated gnome-panel-2.x
+ econf \
+ --disable-gnome \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable fam) \
+ $(use_with password) \
+ $(use_with password password-string ${RANDOM}${RANDOM}${RANDOM}${RANDOM})
+}