summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-05 20:10:05 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-05 20:18:55 +0300
commitaaa7db388b0682c9e1c0d191fb673ea2354558bc (patch)
tree059299424c4e90e80704ca4aa4d83aa4b075a4d2
parentdev-python/sentry-sdk: add 1.22.1 (diff)
downloadgentoo-aaa7db388b0682c9e1c0d191fb673ea2354558bc.tar.gz
gentoo-aaa7db388b0682c9e1c0d191fb673ea2354558bc.tar.bz2
gentoo-aaa7db388b0682c9e1c0d191fb673ea2354558bc.zip
dev-python/rq: add 1.14.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.14.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 2cd1714dd9a4..e26122540200 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,2 +1,3 @@
DIST rq-1.13.0.gh.tar.gz 616679 BLAKE2B 026914ab01f769797e1f7fabc944b5ccdeb1ce1957c7acc72d067e0bdd113ebb30f0060ea5adbceaac5e69b40e176c09a0b1f216cffb02132772e72151b79986 SHA512 6c3b4bb868cae6ffd07718b3f517350eba2effc1b3ae70ef601984cc525ecfb3f82f8569a2b0f333c5f248d3befbe3d4953f5058f8e9cb2f08ce6dadae963902
+DIST rq-1.14.1.gh.tar.gz 628713 BLAKE2B fbd0904faa64ea3207636f765e36042ed8ca2f0b3b57c634c3f9a6254cab811725719bb3c3974f9e19f173e4422355119f550c09a7176e1a4fca26cf26bb6e5d SHA512 f75fe944c041fb8dfe9607b480dbf62d72f8715934e014b4c666f19c73123e7062ab0e17190f572b2cdad6a916dbf2190637255af5c1db51b41765d448ad2120
DIST rq-1.14.gh.tar.gz 627836 BLAKE2B 4127d6c183826ee84eb290145098b545938cdeca2daf836c08ae49a07265cebfc4eb0dbdd92c640605ce630e37a13184010dd8a6a2a2face5369c00c22fc286c SHA512 5e74a2b57b673ef9333dd1ec3f7f3cecb9c9b2d48d93617dd46de833a6edce213b2488822d77eea9fde42f9949fa5e935be4d8f95f43b29e6c8f0f46593d5ce5
diff --git a/dev-python/rq/rq-1.14.1.ebuild b/dev-python/rq/rq-1.14.1.ebuild
new file mode 100644
index 000000000000..a7000a2beeb7
--- /dev/null
+++ b/dev-python/rq/rq-1.14.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="
+ https://python-rq.org/
+ https://github.com/rq/rq/
+ https://pypi.org/project/rq/
+"
+# Tests missing from sdist, as of 1.14.1
+SRC_URI="
+ https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-3.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/sentry-sdk[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ /usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the actual tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}