summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-31 09:19:55 +0000
committerSam James <sam@gentoo.org>2021-10-31 09:19:55 +0000
commitaaad7203e82a69cfde21d34a43da180daddf989a (patch)
tree3160c70ef34c25eb1b18b9d30b2bda6a6e15eec2
parentmedia-sound/beets: fix dependencies (diff)
downloadgentoo-aaad7203.tar.gz
gentoo-aaad7203.tar.bz2
gentoo-aaad7203.zip
net-libs/libtorrent-rasterbar: fix build with python + gnutls
Closes: https://bugs.gentoo.org/820836 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-asio-ssl-error.patch29
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r5.ebuild1
2 files changed, 30 insertions, 0 deletions
diff --git a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-asio-ssl-error.patch b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-asio-ssl-error.patch
new file mode 100644
index 000000000000..16c274c21351
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-asio-ssl-error.patch
@@ -0,0 +1,29 @@
+From 61ebb3317b1f8a63fcf4d018a21dac6818ea21cf Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 31 Oct 2021 09:16:46 +0000
+Subject: [PATCH] Add missing include for get_ssl_category
+
+error::get_ssl_category is defined in boost/asio/ssl/error.hpp, so
+include it when we're building with SSL support.
+
+Bug: https://bugs.gentoo.org/820836
+
+---
+ bindings/python/src/error_code.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/bindings/python/src/error_code.cpp b/bindings/python/src/error_code.cpp
+index 2fc5f42..b947119 100644
+--- a/bindings/python/src/error_code.cpp
++++ b/bindings/python/src/error_code.cpp
+@@ -49,6 +49,7 @@ namespace boost
+
+ #include <boost/asio/error.hpp>
+ #if TORRENT_USE_SSL
++#include <boost/asio/ssl/error.hpp>
+ #include <libtorrent/ssl.hpp>
+ #endif
+ #if TORRENT_USE_I2P
+--
+2.33.1
+
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r5.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r5.ebuild
index 9ea627318a8f..cf17459e25a7 100644
--- a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r5.ebuild
+++ b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r5.ebuild
@@ -44,6 +44,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.0.4-boost-1.76.patch
"${FILESDIR}"/${P}-boost-1.77.patch
"${FILESDIR}"/${P}-python-symbols.patch
+ "${FILESDIR}"/${PN}-2.0.4-asio-ssl-error.patch
)
pkg_setup() {