summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2022-07-12 19:23:21 -0600
committerChristoph Junghans <junghans@gentoo.org>2022-07-12 19:23:51 -0600
commitaab3a914e14666ca962175f3b6a4ad64589e79ed (patch)
tree1057e3a3936f4a5f7f98d74bb5985d114b14f75f
parentnet-libs/uhttpmock: Version bump to 0.5.5 (diff)
downloadgentoo-aab3a914e14666ca962175f3b6a4ad64589e79ed.tar.gz
gentoo-aab3a914e14666ca962175f3b6a4ad64589e79ed.tar.bz2
gentoo-aab3a914e14666ca962175f3b6a4ad64589e79ed.zip
dev-ml/gapi-ocaml: initial commit
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
-rw-r--r--dev-ml/gapi-ocaml/Manifest1
-rw-r--r--dev-ml/gapi-ocaml/files/gapi-ocaml-0.4.2-ounit2.patch58
-rw-r--r--dev-ml/gapi-ocaml/gapi-ocaml-0.4.2-r1.ebuild33
-rw-r--r--dev-ml/gapi-ocaml/metadata.xml24
4 files changed, 116 insertions, 0 deletions
diff --git a/dev-ml/gapi-ocaml/Manifest b/dev-ml/gapi-ocaml/Manifest
new file mode 100644
index 000000000000..e804394c7889
--- /dev/null
+++ b/dev-ml/gapi-ocaml/Manifest
@@ -0,0 +1 @@
+DIST gapi-ocaml-0.4.2.tar.gz 466749 BLAKE2B 6a3e66618ed9a665de2892dc7657268f3bad43b871d6d761148152d61de2d988bc13b5051e39da4d1ddad0c620237c6018b87cd2303bc086c570aa879c197e4f SHA512 57d933c2d47ef7b80cb55b661f8df1b8642ff301d54f0fd1dfd4a9bc6238a4cb93a308e6918bbbc080fac146cf5fca2ccfe149d0528a63ead5e29e452c9cc427
diff --git a/dev-ml/gapi-ocaml/files/gapi-ocaml-0.4.2-ounit2.patch b/dev-ml/gapi-ocaml/files/gapi-ocaml-0.4.2-ounit2.patch
new file mode 100644
index 000000000000..36098d82ed67
--- /dev/null
+++ b/dev-ml/gapi-ocaml/files/gapi-ocaml-0.4.2-ounit2.patch
@@ -0,0 +1,58 @@
+diff --git a/gapi-ocaml.opam b/gapi-ocaml.opam
+index cb9b0fb5..923675d8 100644
+--- a/gapi-ocaml.opam
++++ b/gapi-ocaml.opam
+@@ -15,7 +15,7 @@ depends: [
+ "dune"
+ "ocamlnet" {>= "4.1.4"}
+ "ocurl"
+- "ounit" {with-test}
++ "ounit2" {with-test}
+ "yojson"
+ ]
+ synopsis: "A simple OCaml client for Google Services"
+diff --git a/src/test/dune b/src/test/dune
+index 5d955f42..ef45f0ce 100644
+--- a/src/test/dune
++++ b/src/test/dune
+@@ -1,7 +1,7 @@
+ (executable
+ (name testSuite)
+ (flags (:standard -w -3-6-23-27-32-33-50))
+- (libraries threads oUnit gapi-ocaml))
++ (libraries threads ounit2 gapi-ocaml))
+
+ (alias
+ (name runtest)
+diff --git a/src/test/testSuite.ml b/src/test/testSuite.ml
+index 7851661e..150781f7 100644
+--- a/src/test/testSuite.ml
++++ b/src/test/testSuite.ml
+@@ -76,11 +76,11 @@ let build_suite_from_list test_list =
+
+ let _ =
+ let test_list = ref (core_tests @ model_tests) in
+- let ounit_specs =
++ let ounit2_specs =
+ [
+- ("-verbose", Arg.Unit (fun _ -> ()), "See oUnit doc");
+- ("-only-test", Arg.String (fun _ -> ()), "See oUnit doc");
+- ("-list-test", Arg.String (fun _ -> ()), "See oUnit doc");
++ ("-verbose", Arg.Unit (fun _ -> ()), "See ounit2 doc");
++ ("-only-test", Arg.String (fun _ -> ()), "See ounit2 doc");
++ ("-list-test", Arg.String (fun _ -> ()), "See ounit2 doc");
+ ]
+ in
+ let arg_specs =
+@@ -100,9 +100,9 @@ let _ =
+ ]
+ in
+ let _ =
+- Arg.parse (arg_specs @ ounit_specs)
++ Arg.parse (arg_specs @ ounit2_specs)
+ (fun _ -> ())
+- ("Usage: " ^ Sys.argv.(0) ^ " [-service svc] [-all] [oUnit arguments]")
++ ("Usage: " ^ Sys.argv.(0) ^ " [-service svc] [-all] [ounit2 arguments]")
+ in
+ let _ =
+ (* Reset argument counter, to let OUnit reparse arguments *)
diff --git a/dev-ml/gapi-ocaml/gapi-ocaml-0.4.2-r1.ebuild b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..156be6ded14c
--- /dev/null
+++ b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune findlib
+
+DESCRIPTION="A simple OCaml client for Google Services"
+HOMEPAGE="
+ https://opam.ocaml.org/packages/gapi-ocaml/
+ https://github.com/astrada/gapi-ocaml
+"
+
+SRC_URI="https://github.com/astrada/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RDEPEND="
+ dev-ml/ocurl:=
+ >=dev-ml/ocamlnet-4.1.4:=
+ dev-ml/cryptokit:=
+ <dev-ml/yojson-2:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-ml/ounit2 )
+"
+
+RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/${P}-ounit2.patch" )
diff --git a/dev-ml/gapi-ocaml/metadata.xml b/dev-ml/gapi-ocaml/metadata.xml
new file mode 100644
index 000000000000..550aa3b52af7
--- /dev/null
+++ b/dev-ml/gapi-ocaml/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription lang="en">gapi-ocaml is a simple, unofficial, OCaml client for Google Services.
+The library supports ClientLogin, OAuth 1.0a, and OAuth 2.0
+authentication. Supported RESTful APIs: Calendar APIs v3, Google+ API
+v1, Tasks API v1, APIs Discovery Service v1, URL Shortener API v1,
+OAuth2 API v2, Custom Search API v1, Google Analytics API v3, Page
+Speed Online API v1, Blogger API v2, Site Verification API v1, AdSense
+Management API v1.4, BigQuery API v2, Drive API v2, Drive API v3,
+Gmail API v1.</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/astrada/gapi-ocaml/issues</bugs-to>
+ <remote-id type="github">astrada/gapi-ocaml</remote-id>
+ <maintainer>
+ <name>Alessandro Strada</name>
+ <email>alessandro.strada@gmail.com</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>