summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-01 17:18:15 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-01 17:18:15 +0100
commitaac794e8bf19a982d62b9f8bc53bfa47892e0553 (patch)
treeccf470bf69a126da6f7a9099afadb11a2d3f8c09
parentnet-im/dino: stabilize 0.3.0 for amd64 (diff)
downloadgentoo-aac794e8.tar.gz
gentoo-aac794e8.tar.bz2
gentoo-aac794e8.zip
net-im/dino: drop 0.2.1-r1
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-im/dino/Manifest1
-rw-r--r--net-im/dino/dino-0.2.1-r1.ebuild78
2 files changed, 0 insertions, 79 deletions
diff --git a/net-im/dino/Manifest b/net-im/dino/Manifest
index 0c5caf3183b0..20cbe5460593 100644
--- a/net-im/dino/Manifest
+++ b/net-im/dino/Manifest
@@ -1,2 +1 @@
-DIST dino-0.2.1.tar.gz 514504 BLAKE2B 42fae18bb7cda276c1eadeefdea130069f9929dfde62855f00ab6b88912fe9db3374315f40ff8f53350cf38e45fe61b0fd6256ef390cdbed6a65a3f2d79ac80a SHA512 b71497ec115945eadf7d33bb973f68465a20284aa75f37f1ae25fc30c1c423ce28cb10f7e9123c47f82e77e97170b8fa72c75389dacc3a2aa3d487a9c9610d49
DIST dino-0.3.0.tar.gz 804810 BLAKE2B cb6365f6fad051d0308909c6d5d2c59d7f57cb94f9f691516e27b7bb3aba214fdffa95066d8203d8ac5bd770bec1580e81baad313beef7fe5c058e1e94a37556 SHA512 e3d885208451b00b0416a1401780a94a169fb1179b2f609f7965e3445873d6b72ded84cb471d534616892ec89b5edcd6701fc97c36f19d690f4b894399000515
diff --git a/net-im/dino/dino-0.2.1-r1.ebuild b/net-im/dino/dino-0.2.1-r1.ebuild
deleted file mode 100644
index cf654bee3386..000000000000
--- a/net-im/dino/dino-0.2.1-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_MAKEFILE_GENERATOR="ninja"
-inherit cmake vala xdg
-
-DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
-HOMEPAGE="https://dino.im"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+gpg +http +omemo +notification-sound test"
-RESTRICT="!test? ( test )"
-
-MY_REPO_URI="https://github.com/dino/dino"
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="${MY_REPO_URI}.git"
- inherit git-r3
-else
- KEYWORDS="amd64 arm64"
- SRC_URI="${MY_REPO_URI}/releases/download/v${PV}/${P}.tar.gz"
-fi
-
-RDEPEND="
- app-text/gspell[vala]
- dev-db/sqlite:3
- dev-libs/glib:2
- dev-libs/icu
- dev-libs/libgee:0.8
- net-libs/glib-networking
- net-libs/libsignal-protocol-c
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
- x11-libs/pango
- gpg? ( app-crypt/gpgme:= )
- http? ( net-libs/libsoup:2.4 )
- omemo? (
- dev-libs/libgcrypt:0
- media-gfx/qrencode
- )
- notification-sound? ( media-libs/libcanberra:0[sound] )
-"
-DEPEND="
- $(vala_depend)
- ${RDEPEND}
- sys-devel/gettext
-"
-
-src_prepare() {
- cmake_src_prepare
- vala_src_prepare
-}
-
-src_configure() {
- local disabled_plugins=(
- $(usex gpg "" "openpgp")
- $(usex omemo "" "omemo")
- $(usex http "" "http-files")
- )
- local enabled_plugins=(
- $(usex notification-sound "notification-sound" "")
- )
- local mycmakeargs+=(
- "-DENABLED_PLUGINS=$(local IFS=";"; echo "${enabled_plugins[*]}")"
- "-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
- "-DVALA_EXECUTABLE=${VALAC}"
- "-DBUILD_TESTS=$(usex test)"
- )
-
- cmake_src_configure
-}
-
-src_test() {
- "${BUILD_DIR}"/xmpp-vala-test || die
-}