summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-03-20 18:33:49 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-03-20 18:35:35 -0500
commitaace9367076c4aca4d19559bb48b02742f119f9a (patch)
tree31b5f20c9c256359d2233d196fd529b525744606
parentnet-analyzer/icinga2: 2.10.4 bump (diff)
downloadgentoo-aace9367.tar.gz
gentoo-aace9367.tar.bz2
gentoo-aace9367.zip
media-libs/lsp-plugins: 1.1.7 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--media-libs/lsp-plugins/Manifest1
-rw-r--r--media-libs/lsp-plugins/lsp-plugins-1.1.7.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/lsp-plugins/Manifest b/media-libs/lsp-plugins/Manifest
index 74f90e7c1587..1fe4e34aaba1 100644
--- a/media-libs/lsp-plugins/Manifest
+++ b/media-libs/lsp-plugins/Manifest
@@ -1 +1,2 @@
DIST lsp-plugins-1.1.5.tar.gz 51911033 BLAKE2B ec9b6f3715f1043537ebe35d14abda85b8dfe23d52d335c54c02eb2867753c9b256a5acd71537c95d6da273d054f0e0c9439fe2f81f6d6ced3087de93bfaef60 SHA512 42b9cd102247a0165a32f82a5a7ce05928a9703c80f215783ad67020d1f975d1c334af1f86c9f17e76bea3fd90bcf5c47fff5618875038b3655621880b60a699
+DIST lsp-plugins-1.1.7.tar.gz 52408312 BLAKE2B 1763d7aaff60c4bf3185325789925dc7e5ea1052907f0d1ee3af7c09d39d1f49dfdda537c29d1d2e1ed2bd041345fb3f32a444aa403521f6d4fbd7a952f9f7cb SHA512 e98000c98464abc1db75e044bc1b7adb535b94fbe1025a52baf0a2c92bcd21039c9b330e790f0607b4747356aff3f7d4ae20e666a9135108e875057c5459c8ae
diff --git a/media-libs/lsp-plugins/lsp-plugins-1.1.7.ebuild b/media-libs/lsp-plugins/lsp-plugins-1.1.7.ebuild
new file mode 100644
index 000000000000..f681f70629d3
--- /dev/null
+++ b/media-libs/lsp-plugins/lsp-plugins-1.1.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Linux Studio Plugins"
+HOMEPAGE="https://lsp-plug.in"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/sadko4u/lsp-plugins"
+ EGIT_BRANCH="devel"
+else
+ SRC_URI="https://github.com/sadko4u/lsp-plugins/archive/${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${P}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="doc jack ladspa +lv2"
+REQUIRED_USE="|| ( jack ladspa lv2 )"
+
+DEPEND="
+ dev-libs/expat
+ media-libs/libsndfile
+ doc? ( dev-lang/php:* )
+ jack? (
+ virtual/jack
+ x11-libs/cairo[X]
+ )
+ ladspa? ( media-libs/ladspa-sdk )
+ lv2? (
+ media-libs/lv2
+ x11-libs/cairo[X]
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile(){
+ use doc && MODULES+="doc"
+ use jack && MODULES+=" jack"
+ use ladspa && MODULES+=" ladspa"
+ use lv2 && MODULES+=" lv2"
+ emake BUILD_MODULES="${MODULES}"
+}
+
+src_install(){
+ emake PREFIX="/usr" DESTDIR="${D}" LIB_PATH="/usr/$(get_libdir)" install
+}