summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-10 21:42:30 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-10 21:42:30 +0300
commitaae6399a867e039b0055fddbf11039841e981e93 (patch)
treea7d281a78ea77d90b370538aaf467b8090f99f51
parentmedia-gfx/inkscape: Keyword 1.2.1-r2 hppa, #859184 (diff)
downloadgentoo-aae6399a.tar.gz
gentoo-aae6399a.tar.bz2
gentoo-aae6399a.zip
dev-python/hatch-fancy-pypi-readme: add 22.5.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/hatch-fancy-pypi-readme/Manifest1
-rw-r--r--dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.5.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/hatch-fancy-pypi-readme/Manifest b/dev-python/hatch-fancy-pypi-readme/Manifest
index 172765ae3b7b..a157a6e7ff60 100644
--- a/dev-python/hatch-fancy-pypi-readme/Manifest
+++ b/dev-python/hatch-fancy-pypi-readme/Manifest
@@ -1 +1,2 @@
DIST hatch-fancy-pypi-readme-22.3.0.gh.tar.gz 22107 BLAKE2B 7358a35ed9176d5107d406c1f99cfcf17ce409224dcad55ac845087e2fd6cc9ab88e5ea929e3b1304bbff6464cbbbd0b0d9716bcfe199dcd887c809cd6a9356a SHA512 93fe293ddce6dde450bc427d8fa492cf2b1f7d4a0e2d754873f765f588a962ca2c7c48b515ba613503bed6100b302ed91bbedb4d6a9f8d7bc10ab4b1418164e8
+DIST hatch-fancy-pypi-readme-22.5.0.gh.tar.gz 27046 BLAKE2B 9ad22d9c8a694a9580efe436a65d14a906b9bc2da6f9bdac0488bb69c6bead31b7a54162f3d3e444ee00d4b73c451b95bdd41ae07f584a65ce1cd5b6d663f257 SHA512 4652e40e45eab3606e53b8f9915247687088ffd7dbfa6ad00f4507a62c0225e72b1f66a21ab6e1cdc98386958eed8c2991facd75ee4295fa078995e1344e1b25
diff --git a/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.5.0.ebuild b/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.5.0.ebuild
new file mode 100644
index 000000000000..3a081f252756
--- /dev/null
+++ b/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Fancy PyPI READMEs with Hatch"
+HOMEPAGE="
+ https://pypi.org/project/hatch-fancy-pypi-readme/
+ https://github.com/hynek/hatch-fancy-pypi-readme
+"
+SRC_URI="
+ https://github.com/hynek/hatch-fancy-pypi-readme/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/hatchling[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tests for self build a wheel? No need for that and fails.
+ tests/test_end_to_end.py
+)