summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2023-04-10 11:53:09 +0200
committerFabian Groffen <grobian@gentoo.org>2023-04-10 11:54:57 +0200
commitaaf40db76b7b4847b100eac9921aeb990614ca77 (patch)
treed0be46b00494a10191a30b0245fc1f8f8fdcce11
parentnet-misc/trurl: add 0.4 (diff)
downloadgentoo-aaf40db76b7b4847b100eac9921aeb990614ca77.tar.gz
gentoo-aaf40db76b7b4847b100eac9921aeb990614ca77.tar.bz2
gentoo-aaf40db76b7b4847b100eac9921aeb990614ca77.zip
app-metrics/carbonapi-web: initial commit
This package can be used as replacement for net-analyzer/graphite-web in deployments where app-metrics/carbonapi-booking and app-metrics/go-carbon are used instead of the Python-based variants. Bug: https://bugs.gentoo.org/897056 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--app-metrics/carbonapi-web/Manifest1
-rw-r--r--app-metrics/carbonapi-web/carbonapi-web-1.0.ebuild28
-rw-r--r--app-metrics/carbonapi-web/files/postinstall-en.txt12
-rw-r--r--app-metrics/carbonapi-web/metadata.xml11
4 files changed, 52 insertions, 0 deletions
diff --git a/app-metrics/carbonapi-web/Manifest b/app-metrics/carbonapi-web/Manifest
new file mode 100644
index 000000000000..a61f570231b9
--- /dev/null
+++ b/app-metrics/carbonapi-web/Manifest
@@ -0,0 +1 @@
+DIST carbonapi-web-1.0.tar.gz 1026954 BLAKE2B e482565b103b7afcfb7e2d778e57b24610713568f7ec079247b8dbd9f1f46668f0487eefef6d34e27bb0985bf5bc9bb6edb1a1d22652ff0db575b32099586c5f SHA512 56a048d414aae2db99a29aca46ebe0c58e738acdae44ffa0b82478559dd0e2327767682941e69d5cda0c716cf7121c2f90d40b9866943b735d424c4b5b283e5c
diff --git a/app-metrics/carbonapi-web/carbonapi-web-1.0.ebuild b/app-metrics/carbonapi-web/carbonapi-web-1.0.ebuild
new file mode 100644
index 000000000000..3da2ea912f27
--- /dev/null
+++ b/app-metrics/carbonapi-web/carbonapi-web-1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="graphite-web fork for standalone usage with carbonapi"
+HOMEPAGE="https://github.com/grobian/carbonapi-web"
+SRC_URI="https://github.com/grobian/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r webapp/content/*
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
diff --git a/app-metrics/carbonapi-web/files/postinstall-en.txt b/app-metrics/carbonapi-web/files/postinstall-en.txt
new file mode 100644
index 000000000000..26cd2dc8abb0
--- /dev/null
+++ b/app-metrics/carbonapi-web/files/postinstall-en.txt
@@ -0,0 +1,12 @@
+1. install and setup a Graphite resolving and rendering instance such as
+ app-metrics/carbonapi-booking
+2. setup a vhost that:
+ - uses default index file browser.html
+ - proxies these paths down to the Graphite rendering instance:
+ * /render/
+ * /metrics/
+ * /info/
+ * /functions/
+ * /tags/
+3. the combined setup should load the web browser and interact with your
+ Graphite install
diff --git a/app-metrics/carbonapi-web/metadata.xml b/app-metrics/carbonapi-web/metadata.xml
new file mode 100644
index 000000000000..d431e6b2a193
--- /dev/null
+++ b/app-metrics/carbonapi-web/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grobian@gentoo.org</email>
+ <name>Fabian Groffen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">grobian/carbonapi-web</remote-id>
+ </upstream>
+</pkgmetadata>