summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-07-31 09:36:19 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-07-31 10:00:39 +0200
commitab06fefb5582eac9e1682b03ddcd304bd5bca662 (patch)
treef8744d1f8ceb9835a1e5e07c6c9341b795b0d6c9
parentdev-python/python-lzo: version bump. (diff)
downloadgentoo-ab06fefb.tar.gz
gentoo-ab06fefb.tar.bz2
gentoo-ab06fefb.zip
dev-python/python-daemon: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-python/python-daemon/Manifest1
-rw-r--r--dev-python/python-daemon/python-daemon-2.1.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-daemon/Manifest b/dev-python/python-daemon/Manifest
index d446b997da27..581aa978f544 100644
--- a/dev-python/python-daemon/Manifest
+++ b/dev-python/python-daemon/Manifest
@@ -1,2 +1,3 @@
DIST python-daemon-1.6.tar.gz 41564 BLAKE2B 6ed3dcced0deef859efc733be38d807726ad89c405a2b83bbc05d0e22f8bba64521a82f1127d28b6f69c6553c375f3607d1904e5b6ff190741b0b3c399054953 SHA512 ff9480844d8f57a09f27067aaa78669c167f66b2cc05f9b3baa660bc0aa21228d4894eeaeb3440611c1e0f0d5633b1c60eac60893da4a86d1db4b94d99961299
DIST python-daemon-2.1.1.tar.gz 74276 BLAKE2B c2ca4d1680555a559009224391151cdffbaf49ee03c0a2985184b336a3d1a8c8372423b3b527199daa5f38a29d52fc879f18a719531afeb18642f7d6cb59df51 SHA512 e2abb9fafea32fe5bc7d239387e3c22aa99f63df31cc4f57908ffdb5dc7f2768358df6ba5f3e827b4f83163628649f58a973b548066e8c79ab3c6c6ce09d8007
+DIST python-daemon-2.1.2.tar.gz 76176 BLAKE2B f8252bb3ee23b9d2a4ac33057df98720708b2a7e10c38c188c537d3c90ad641e33ba73e39f1bbfca10655e2ebd5d550179ed55d09a2f767832fa1d26accc9e21 SHA512 28ae118fd652a0a26524215568df0b16264e3a844640fe47f0a08c45c7a16be1b60d78293c2fc13edfe1402a8b5dcd72ec11101c3b53e5b66f232b7e21d5d346
diff --git a/dev-python/python-daemon/python-daemon-2.1.2.ebuild b/dev-python/python-daemon/python-daemon-2.1.2.ebuild
new file mode 100644
index 000000000000..ae66b2d9571c
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-2.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="https://pypi.org/project/python-daemon/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/lockfile[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ test? (
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}