summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-07 07:51:56 +0100
committerSam James <sam@gentoo.org>2022-05-15 01:00:08 +0000
commitab09010cb0757f4c06d211a81f24f51ceceb917e (patch)
tree08a0ba6c68c1840186447d48d13f0bcd872c0865
parentsci-mathematics/agda-stdlib: egrep -> grep -E (diff)
downloadgentoo-ab09010cb0757f4c06d211a81f24f51ceceb917e.tar.gz
gentoo-ab09010cb0757f4c06d211a81f24f51ceceb917e.tar.bz2
gentoo-ab09010cb0757f4c06d211a81f24f51ceceb917e.zip
app-admin/testdisk: egrep -> grep -E
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-admin/testdisk/testdisk-7.1-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-admin/testdisk/testdisk-7.1-r1.ebuild b/app-admin/testdisk/testdisk-7.1-r1.ebuild
index 2532bfd25503..6ac500bd0a2a 100644
--- a/app-admin/testdisk/testdisk-7.1-r1.ebuild
+++ b/app-admin/testdisk/testdisk-7.1-r1.ebuild
@@ -73,13 +73,13 @@ src_configure() {
econf "${myconf[@]}"
# perform safety checks for NTFS, REISERFS and JPEG
- if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
+ if use ntfs && ! grep -E -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
die "Failed to find either NTFS or NTFS-3G library."
fi
- if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
+ if use reiserfs && grep -E -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
die "Failed to find reiserfs library."
fi
- if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
+ if use jpeg && grep -E -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
die "Failed to find jpeg library."
fi
}