summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 12:26:34 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 16:54:17 +0100
commitab0afda12a94a22da7afdfb42bcd6f2f6c0742f8 (patch)
treec4cba3cab263083bfe2b480cc3c7c98214c28129
parentapp-admin/calamares: Switch to python-single-r1 (diff)
downloadgentoo-ab0afda1.tar.gz
gentoo-ab0afda1.tar.bz2
gentoo-ab0afda1.zip
dev-python/basemap: Switch to python-single-r1
basemap needs to be single-r1 since its dependency sci-libs/geos is. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/basemap/basemap-1.0.7-r2.ebuild (renamed from dev-python/basemap/basemap-1.0.7-r1.ebuild)28
-rw-r--r--dev-python/basemap/basemap-1.0.7-r4.ebuild (renamed from dev-python/basemap/basemap-1.0.7-r3.ebuild)28
2 files changed, 30 insertions, 26 deletions
diff --git a/dev-python/basemap/basemap-1.0.7-r1.ebuild b/dev-python/basemap/basemap-1.0.7-r2.ebuild
index 21c1f248697e..f6f476179223 100644
--- a/dev-python/basemap/basemap-1.0.7-r1.ebuild
+++ b/dev-python/basemap/basemap-1.0.7-r2.ebuild
@@ -3,6 +3,7 @@
EAPI=5
+DISTUTILS_SINGLE_IMPL=1
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 flag-o-matic
@@ -16,20 +17,21 @@ SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
LICENSE="MIT GPL-2"
-CDEPEND="sci-libs/shapelib
- || (
- >=dev-python/matplotlib-python2-0.98[${PYTHON_USEDEP}]
- >=dev-python/matplotlib-0.98[${PYTHON_USEDEP}]
- )
- >=sci-libs/geos-3.3.1[python(-),${PYTHON_USEDEP}]"
+DEPEND="sci-libs/shapelib
+ $(python_gen_cond_dep '
+ || (
+ >=dev-python/matplotlib-python2-0.98[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/matplotlib-0.98[${PYTHON_MULTI_USEDEP}]
+ )
+ ')
+ >=sci-libs/geos-3.3.1[python(-),${PYTHON_SINGLE_USEDEP}]"
-DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-RDEPEND="${CDEPEND}
- >=dev-python/pupynere-1.0.8[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/dap[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/pupynere-1.0.8[${PYTHON_MULTI_USEDEP}]
+ dev-python/httplib2[${PYTHON_MULTI_USEDEP}]
+ dev-python/dap[${PYTHON_MULTI_USEDEP}]
+ ')"
DOCS="FAQ API_CHANGES"
#REQUIRED_USE="test? ( examples )"
diff --git a/dev-python/basemap/basemap-1.0.7-r3.ebuild b/dev-python/basemap/basemap-1.0.7-r4.ebuild
index 97bcfc3f839b..38c0bfb4645e 100644
--- a/dev-python/basemap/basemap-1.0.7-r3.ebuild
+++ b/dev-python/basemap/basemap-1.0.7-r4.ebuild
@@ -3,6 +3,7 @@
EAPI=5
+DISTUTILS_SINGLE_IMPL=1
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 flag-o-matic
@@ -16,20 +17,21 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="MIT GPL-2"
-CDEPEND="sci-libs/shapelib
- || (
- >=dev-python/matplotlib-python2-0.98[${PYTHON_USEDEP}]
- >=dev-python/matplotlib-0.98[${PYTHON_USEDEP}]
- )
- >=sci-libs/geos-3.3.1[python(-),${PYTHON_USEDEP}]"
+DEPEND="sci-libs/shapelib
+ $(python_gen_cond_dep '
+ || (
+ >=dev-python/matplotlib-python2-0.98[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/matplotlib-0.98[${PYTHON_MULTI_USEDEP}]
+ )
+ ')
+ >=sci-libs/geos-3.3.1[python(-),${PYTHON_SINGLE_USEDEP}]"
-DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-RDEPEND="${CDEPEND}
- >=dev-python/pupynere-1.0.8[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/dap[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/pupynere-1.0.8[${PYTHON_MULTI_USEDEP}]
+ dev-python/httplib2[${PYTHON_MULTI_USEDEP}]
+ dev-python/dap[${PYTHON_MULTI_USEDEP}]
+ ')"
DOCS="FAQ API_CHANGES"
#REQUIRED_USE="test? ( examples )"