summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-11-07 01:31:43 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-11-07 03:37:54 -0500
commitab18eb6f8572af5ef6b4e3643b8aebb2aef1df75 (patch)
treee25f6db983fa67117a4b3d2a80c7fbd374336546
parentdev-python/pytest-bdd: disable pytest plugins autoload (diff)
downloadgentoo-ab18eb6f.tar.gz
gentoo-ab18eb6f.tar.bz2
gentoo-ab18eb6f.zip
dev-python/pytest-bdd: add 5.0.0
4.1.0 will be kept for an extended period given may need migration. This /would/ break some of qutebrowser tests due to a change with how it treats < used for keys in e.g. "<tab>", but these end2end tests were already skipped due to QT IPC path length limitations (see ebuild). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-python/pytest-bdd/Manifest1
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-5.0.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index 6a2dda084830..d95a711031b3 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1 +1,2 @@
DIST pytest-bdd-4.1.0.tar.gz 61079 BLAKE2B 3bf7863b7244e0fa02de48f3c8d113427c9a9d546d1a5d95dbc025bcdf0bd60931fac55d7328c96a3b29b8b15da833c85c089cee19ee4f8a2bc639dd1b3c4e59 SHA512 54ce5ae2f7b3deff7d436d42f80fc47892707eb1e6e76469dda9753ff0b2d727bb47b5be300eadccadd87838aee43130fec5dff6441353eb07c0787c84d55afa
+DIST pytest-bdd-5.0.0.tar.gz 61174 BLAKE2B 6dd1d53614226d3515b0f61f71822363b559aa45789bab7f3416c75e603e87a1fe48627f36862f44bfa7ac6ec5023ad8afde6054ec67fc9a2e756be7de729fd1 SHA512 827e57d410b05207b6c646062ddb54b677e22441311820d3bd406df202b6e9344dedf59cd4868e89cfbf8606fe3f15559e4cc3958d100e4fa74f9b864e6faada
diff --git a/dev-python/pytest-bdd/pytest-bdd-5.0.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-5.0.0.ebuild
new file mode 100644
index 000000000000..e429be77bf70
--- /dev/null
+++ b/dev-python/pytest-bdd/pytest-bdd-5.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="BDD library for the pytest runner"
+HOMEPAGE="https://pypi.org/project/pytest-bdd/"
+SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/glob2[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ dev-python/parse_type[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
+
+distutils_enable_tests --install pytest
+
+DOCS=( AUTHORS.rst CHANGES.rst README.rst )
+
+src_test() {
+ # terminal_reporter test needs exact wrapping
+ local -x COLUMNS=80
+
+ # hooks output parsing may be affected by other pytest-*, e.g. tornasync
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_bdd.plugin
+
+ distutils-r1_src_test
+}