summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-27 13:55:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-24 16:16:50 +0200
commitab1ac64cf03474ccc6ba854478e9eb1ed3183670 (patch)
tree0076618b116280fe84aff053313d401233745283
parentdev-qt/qtcore: Don't access QObjectPrivate::declarativeData unguarded (diff)
downloadgentoo-ab1ac64c.tar.gz
gentoo-ab1ac64c.tar.bz2
gentoo-ab1ac64c.zip
kde-apps/kdialog: Fix build with USE -X
Upstream commit 0a50669e229a965a61039e5f9f20c345d72231b5 Bug: https://bugs.gentoo.org/813450 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/kdialog/files/kdialog-22.04.3-without_x11.patch44
-rw-r--r--kde-apps/kdialog/kdialog-22.04.3.ebuild4
-rw-r--r--kde-apps/kdialog/kdialog-22.08.0.ebuild4
3 files changed, 50 insertions, 2 deletions
diff --git a/kde-apps/kdialog/files/kdialog-22.04.3-without_x11.patch b/kde-apps/kdialog/files/kdialog-22.04.3-without_x11.patch
new file mode 100644
index 000000000000..d0b7cd2a25f7
--- /dev/null
+++ b/kde-apps/kdialog/files/kdialog-22.04.3-without_x11.patch
@@ -0,0 +1,44 @@
+From 0a50669e229a965a61039e5f9f20c345d72231b5 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 27 Nov 2021 13:52:23 +0100
+Subject: [PATCH] Add CMake option to build WITHOUT_X11
+
+We want to be able to build without X11 support even if some of the used
+libraries may not work w/o X11 themselves yet or need to be built with
+X11 support for other reverse dependencies.
+
+HAVE_X11 already exists and is set automagically so far, but using
+-DCMAKE_DISABLE_FIND_PACKAGE_X11 will break if any dependencies list X11
+as required in their cmake config.
+
+Introducing this option means there is no behavior change by default,
+cmake will just skip finding X11 or adding unwanted features if the
+option is enabled.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2bb478129..8449057db 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -26,10 +26,10 @@ include(FeatureSummary)
+ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS TextWidgets Notifications GuiAddons IconThemes WindowSystem KIO DBusAddons)
+ find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS DBus)
+
+-
+-find_package(X11)
+-if(X11_FOUND)
+- set(HAVE_X11 1)
++option(WITHOUT_X11 "Build without X11 integration (skips finding X11)" OFF)
++if (NOT WITHOUT_X11)
++ find_package(X11)
++ set(HAVE_X11 ${X11_FOUND})
+ endif()
+
+ add_definitions(
+--
+GitLab
+
diff --git a/kde-apps/kdialog/kdialog-22.04.3.ebuild b/kde-apps/kdialog/kdialog-22.04.3.ebuild
index e2d42a868e72..2deab7e89818 100644
--- a/kde-apps/kdialog/kdialog-22.04.3.ebuild
+++ b/kde-apps/kdialog/kdialog-22.04.3.ebuild
@@ -34,9 +34,11 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-without_x11.patch" )
+
src_configure() {
local mycmakeargs=(
- $(cmake_use_find_package X X11)
+ -DWITH_X11=$(usex X)
)
ecm_src_configure
}
diff --git a/kde-apps/kdialog/kdialog-22.08.0.ebuild b/kde-apps/kdialog/kdialog-22.08.0.ebuild
index ca75d0c43665..271d8693ebe1 100644
--- a/kde-apps/kdialog/kdialog-22.08.0.ebuild
+++ b/kde-apps/kdialog/kdialog-22.08.0.ebuild
@@ -34,9 +34,11 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-22.04.3-without_x11.patch" )
+
src_configure() {
local mycmakeargs=(
- $(cmake_use_find_package X X11)
+ -DWITH_X11=$(usex X)
)
ecm_src_configure
}