summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-24 21:01:32 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-24 21:07:24 +0100
commitab20a5ca3ba5242724295bef1d2b681af69a826e (patch)
tree91a8da9753380b136aa6913a2246d1dc11c19923
parentdev-python/leechcorepyc: Remove old (diff)
downloadgentoo-ab20a5ca3ba5242724295bef1d2b681af69a826e.tar.gz
gentoo-ab20a5ca3ba5242724295bef1d2b681af69a826e.tar.bz2
gentoo-ab20a5ca3ba5242724295bef1d2b681af69a826e.zip
dev-python/dask: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2024.1.1.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index a393bdb998f3..23e0283d0fb7 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,3 +1,2 @@
-DIST dask-2024.1.1.gh.tar.gz 9328425 BLAKE2B 6b6208c59e0446816a962a9a3dc6a1754eba589810aacdab0c1ce38edd6d593763d1868578a344babfa74afd390ac1997d2461586b12180679fdc67ae26e0a74 SHA512 a5e424333c5d19f67d73c2b036544ef03122a99c2eb6a52019929f1e7b87297c776cbea713062372cf1685ef3b79d47734d6d0acd2c054ffadcbb3d96fb6deeb
DIST dask-2024.2.0.gh.tar.gz 9335533 BLAKE2B c23bf3da4624b187f30cf0ca5fe885a705e8e4be9b9d919ff491399d1029d43c4343159acf9bd6a61611af7ecacd8c00bd1cb199176b742ad3c556e2a5da65c9 SHA512 8a0b5c17aa34b309aed370852ddfb25cde220de87fe9c1afd8d88f7a4abad9f4523c90424f8a5cc1d7186850f35071ee10e7a33396ca2c4c4be975783cc5fe2e
DIST dask-2024.2.1.gh.tar.gz 9341330 BLAKE2B f5d02fd7389711c5d7b048e541c28af87a8425931277ce035163c16699d7275b802afc90c71256ac268f67390afc9dd4a393df2ddeedac6e378bf787edf43e41 SHA512 3863ec9126ba9fa0cf067a62d3d763d7cf52c6e49cdbfc258336b4536922c46f23443ff8aa4eb49176a38d2a70e03e2d5ca8a2c4b96c98d474654eec4e44c9c5
diff --git a/dev-python/dask/dask-2024.1.1.ebuild b/dev-python/dask/dask-2024.1.1.ebuild
deleted file mode 100644
index fa3e5e77407b..000000000000
--- a/dev-python/dask/dask-2024.1.1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
-HOMEPAGE="
- https://www.dask.org/
- https://github.com/dask/dask/
- https://pypi.org/project/dask/
-"
-SRC_URI="
- https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/click-8.1[${PYTHON_USEDEP}]
- >=dev-python/cloudpickle-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/fsspec-2021.9.0[${PYTHON_USEDEP}]
- >=dev-python/importlib-metadata-4.13.0[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.21[${PYTHON_USEDEP}]
- >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
- >=dev-python/partd-1.2.0[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
- >=dev-python/toolz-0.10.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/toolz[${PYTHON_USEDEP}]
- >=dev-python/versioneer-0.28[${PYTHON_USEDEP}]
- test? (
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/numexpr[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # fails with sqlalchemy-2.0, even though we don't use it x_x
- sed -i -e '/RemovedIn20Warning/d' pyproject.toml || die
- sed -i -e 's:--cov-config=pyproject.toml::' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # more tests relying on -Werror
- "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
- dask/array/tests/test_random.py::test_RandomState_only_funcs
- dask/dataframe/tests/test_dataframe.py::test_view
- dask/dataframe/tests/test_shuffle.py::test_npartitions_auto_raises_deprecation_warning
- # TODO
- dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
- dask/tests/test_config.py::test__get_paths
- dask/array/tests/test_linalg.py::test_solve_assume_a
- "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
- "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
- dask/array/tests/test_image.py::test_preprocess
- dask/tests/test_system.py::test_cpu_count_cgroups_v2
- # require sqlalchemy<2.0
- dask/dataframe/io/tests/test_sql.py
- # crashes
- dask/tests/test_base.py::test_tokenize_object_with_recursion_error
- # regression with new pandas (?)
- dask/dataframe/tests/test_multi.py::test_concat5
- )
-
- if ! has_version -b "dev-python/pyarrow[parquet,${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- # fails if pyarrow is installed without USE=parquet
- # (optional dep, skipped if it's not installed at all)
- dask/dataframe/io/tests/test_parquet.py::test_pyarrow_filter_divisions
- )
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest_rerunfailures -m "not network" \
- -p xdist -n "$(makeopts_jobs)"
-}