summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-27 03:20:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-27 04:03:48 +0200
commitab32c4053f8d71e7b5b1e814878ac704f45fac16 (patch)
tree11c2d0aebd09f4df58ee4125bcbf80e1a4267662
parentdev-python/mypy: add 0.981 (diff)
downloadgentoo-ab32c4053f8d71e7b5b1e814878ac704f45fac16.tar.gz
gentoo-ab32c4053f8d71e7b5b1e814878ac704f45fac16.tar.bz2
gentoo-ab32c4053f8d71e7b5b1e814878ac704f45fac16.zip
dev-python/sentry-sdk: Bump to 1.9.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.9.9.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 56c8d8ce2086..090764fc65c9 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -2,3 +2,4 @@ DIST sentry-sdk-1.9.5.gh.tar.gz 272096 BLAKE2B 179be647b92a74a1836f26add33e4b980
DIST sentry-sdk-1.9.6.gh.tar.gz 270120 BLAKE2B d5918f4ed21f3ee50d76a780416c458b3f917a314a9dfbdbe4b4b63727fa3b7ead61d04546b6ebf57c262143ccc694811e6f888ca1d39155aa98f3225508ab94 SHA512 ad8717f456706edb31e01e8c19b8b81d98b15423d62b2dba8a86fc78a4756c8176b4a0758ebb599f84dd4e6e85258c47e350c8f55e80314a4a70631966c83de6
DIST sentry-sdk-1.9.7.gh.tar.gz 270209 BLAKE2B d1671bb45efa8aa785dc33a5d27e1d44843000809a88c4b081bbaca31be9ece65c6b192cadd46df912e1e1ca8650c7246f9946adb85117e88d13446965e190ac SHA512 d5c9a32e2c4001892cd03357d3b0cfe4c789eb0f4a12f6431920624795d4ed70a4055351541e12d9ee0be6e0fa689190e53c05fac53a27dad30e9f9fbe0711c1
DIST sentry-sdk-1.9.8.gh.tar.gz 271425 BLAKE2B 27135f4fee24d80a544d852261555d8a8498990f815bbe7438b67bbf5717ed4b6e92c8f3e6781929332cbaba75986538294cf4b97c5bbe845ab57a32333d1d6f SHA512 7c9136b4100537e327ccbc2a96967007a1d2de653098ffa3463cc135ca604e49bd066d6a85046c752f38bdfc2698298e46a5d26bbf1a31a19f1631cf92ad9c8d
+DIST sentry-sdk-1.9.9.gh.tar.gz 281232 BLAKE2B 8d1017644c2ae73c4e070f7b1b0a6807ab1d7a7655986bb9a4b457f72c98b3df0fd5f3af8722ea91e13911b1ce6d7234542af195a0b80ec5e9e939f5de3998f0 SHA512 613b504c9e0071657241c7724206d3e99f62fdc846cda98fa4830cf29eee24c8d2ae2abb265fab5d87f47d064d8aed60e105c2d2090fb24308e65b7e74e2974b
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.9.9.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.9.9.ebuild
new file mode 100644
index 000000000000..9d1e2042e8f2
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.9.9.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # requires python-multipart (TODO: package it)
+ tests/integrations/starlette
+)
+
+EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+)