summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-05-17 19:12:31 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-05-17 19:12:31 +0200
commitab37c18d19222a6757139715218c9ee06d828e1d (patch)
treecbd6201d6822f1994394a03705d02acf4d86c4c2
parentdev-php/pecl-rrd: Revbump to add php7-1 support wrt bug 618720 (diff)
downloadgentoo-ab37c18d19222a6757139715218c9ee06d828e1d.tar.gz
gentoo-ab37c18d19222a6757139715218c9ee06d828e1d.tar.bz2
gentoo-ab37c18d19222a6757139715218c9ee06d828e1d.zip
dev-python/node-semver: Add python3_6
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-python/node-semver/node-semver-0.1.1.ebuild18
1 files changed, 15 insertions, 3 deletions
diff --git a/dev-python/node-semver/node-semver-0.1.1.ebuild b/dev-python/node-semver/node-semver-0.1.1.ebuild
index eb9447fc5e20..6285b77acb50 100644
--- a/dev-python/node-semver/node-semver-0.1.1.ebuild
+++ b/dev-python/node-semver/node-semver-0.1.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
inherit distutils-r1
@@ -17,4 +17,16 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
+IUSE="test"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # https://github.com/podhmo/python-semver/issues/4
+ sed -i -e "/github.com/d" semver/tests/test_negative_range.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test || die
+}