summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-01 05:53:27 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-01 08:53:48 +0200
commitab48da657f01d01f51d3c7bf1d84f3c569940a24 (patch)
treedd7f39b3d557d877634e5926d9bf9b031484417c
parentdev-python/botocore: Bump to 1.27.21 (diff)
downloadgentoo-ab48da65.tar.gz
gentoo-ab48da65.tar.bz2
gentoo-ab48da65.zip
dev-python/boto3: Bump to 1.24.21
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.21.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 2279e812fa5f..5e2e320e18e8 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,3 +1,4 @@
DIST boto3-1.24.12.gh.tar.gz 509573 BLAKE2B 5c9978cac1cbce0521dee6f2164652c4fca82b0bf20276e3f4e75960e0877ec0545ca50884daedde115bba117bea424da2ad2fe63e845a32a6f832a3ab5a5841 SHA512 dec940a6e97c51089933a66994b14882f31f2ed7959f966e1f9cd2e6a4a1bb40cc2c01d509ce7346ac345df30d0f164213034c0de97daf3053ba4ea51e5f7495
DIST boto3-1.24.17.gh.tar.gz 511281 BLAKE2B 577efc0ebfb39957e55bcaf7aa678cdf072eed885ab1055b15fc8ca2295fedd6d56fd2fb919913beedcdd335ff26e452bc5434283c9ca9d8f0135080e2aa1312 SHA512 a843146951eb2a5ad7dd31159d833806ae403014abf3e9a617f6457e3ecec1a0dc4c6ce6a87079c9112513cbd6a2ccd26542e5736eeea6c5723c7e39c660befa
DIST boto3-1.24.20.gh.tar.gz 512415 BLAKE2B c2196a9a518b0e4c0fb6e2382390d7d8e275d834a363856c266f696d57b5d56bf7f6a07df10d44670189098b19e0fcfad2a4907af10cd0d6361a5b2164bd6269 SHA512 cb4e426654895e26867a165304d03a722465441e10bf4dfd76fd7c5b45289785ba83f4f66c45d256a5ef6beb3cf5dfa923ea7479e99361344288ad98350a68a6
+DIST boto3-1.24.21.gh.tar.gz 513083 BLAKE2B 1de0405823b6b33efcb11316a3c400180fa3f9064a63023e2f13d6ae18fb6e60ac229ba11c8eb93901d4a6ca65aa32e9ff576b421ffbb6e75476149e93df4d2e SHA512 4f278cbe0bffd2107354aaa76ef7e725a8ea3fcf1688614203204b495be596405fcb0add790922ab09858d94798bc06076c9160f42ff20b855b8a31859c57bc4
diff --git a/dev-python/boto3/boto3-1.24.21.ebuild b/dev-python/boto3/boto3-1.24.21.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.21.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}