summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-26 20:41:15 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-26 20:41:15 +0200
commitab4d62049b362115484c5d0b9c9b56fa517dd668 (patch)
tree3bd678eef1866d9e9fbe38e51b8e592d3852e428
parentx11-misc/xvfb-run: Drop old (diff)
downloadgentoo-ab4d62049b362115484c5d0b9c9b56fa517dd668.tar.gz
gentoo-ab4d62049b362115484c5d0b9c9b56fa517dd668.tar.bz2
gentoo-ab4d62049b362115484c5d0b9c9b56fa517dd668.zip
dev-python/nuitka: add 1.2.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-1.2.3.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 28442d2c742f..71a10c305875 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,4 +1,5 @@
DIST Nuitka-1.1.8.tar.gz 3931273 BLAKE2B 19425e5394f02f4e5dab612e17f80de27569a0d364aaf8597c7bf63f0aa271c3f8cfa987c12b1ae09c5449775b6e4e61aa4d733d0ed81231c4df6ef955dc030e SHA512 f1e594499cd9fcd03873646c41b66a4d89980f408412dcd58db45b3c48238503d03ef25a1b230cfa99960df69f2564b74b02c446e0431dd72634ce277347a551
DIST Nuitka-1.2.1.tar.gz 3958041 BLAKE2B 461fd91fc2948aa131a5295f3e2f8c99d8de26b32d0dd3008ee130bdc8b722a469e458a717b5cbdbf45cd3720dfff828c3eade1d57c7f0ee391cd062105b4ad1 SHA512 98a95342a78c935ebea88446ee875122baeb66290148cf8c454c8287ecc40b092015d710a1a25b35c3b6869138800d2c654b09a3424512536f06d27860bfa2bb
DIST Nuitka-1.2.2.tar.gz 3958127 BLAKE2B fb4fbbf3537d78b5375ef9e26c65bae5a09db2b8839308b8b1ab847c9e820586e84742fd89aa91f8c0bfb366309cc4106ed2195566762103a54951026f81c3b8 SHA512 4b11e15fbb81d3bbf9c687a05ecd71cec7b4f145ad7f1af5a98eb77ff6e4d93bac5e3af8474b9ba0a7bffb5b191f46960e317b53d315455a1ca2ea0660859357
+DIST Nuitka-1.2.3.tar.gz 3958335 BLAKE2B c2d47e7ff355492fb72f224be92445849c3fce13768ba7957cf4bbbbc9cd4e0ec7c3904e5465ad543e16d1419a01b42cd4399b816e1ff56e2c8ea5c57fddbc04 SHA512 1c842c21764bd0dc9bf68bb26506959b35e54d03c1d6d6b9c179289ec073ed07b75d6709a3c73ac3e14bb988a7b2f5a88f7dfcce55a25eab1c5e4b294b15d4f4
DIST Nuitka-1.2.tar.gz 3957227 BLAKE2B e82c8e30ef326254db255785efd2bab1450c2c496bbef1aae35e6f6c42fee09f2454bdff366ecfcf704aa42bbe9cd62ff5a65f26065b85e95083cb0134829dbc SHA512 65c262109f2341aab607601299ec70c88df46218ecc2bb7a7d39ff66b8d4ec43e44a5d30ac936d6572fb141ca6b19e3c0e0c01975dea82d46a2ec190ed13c21b
diff --git a/dev-python/nuitka/nuitka-1.2.3.ebuild b/dev-python/nuitka/nuitka-1.2.3.ebuild
new file mode 100644
index 000000000000..b55f0385d58a
--- /dev/null
+++ b/dev-python/nuitka/nuitka-1.2.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}