summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-10-21 15:56:36 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-10-22 10:05:35 +0200
commitab56db1c767f492ebf32d6d1eee15891b5be57d7 (patch)
treeabc0cbd7f3793abff4c9dae180cec27598fef768
parentnet-p2p/mktorrent: x86 stable wrt bug #817359 (diff)
downloadgentoo-ab56db1c767f492ebf32d6d1eee15891b5be57d7.tar.gz
gentoo-ab56db1c767f492ebf32d6d1eee15891b5be57d7.tar.bz2
gentoo-ab56db1c767f492ebf32d6d1eee15891b5be57d7.zip
dev-java/bnd-junit: remove old
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/22656 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--dev-java/bnd-junit/bnd-junit-2.1.0-r1.ebuild48
-rw-r--r--dev-java/bnd-junit/bnd-junit-2.1.0.ebuild53
2 files changed, 0 insertions, 101 deletions
diff --git a/dev-java/bnd-junit/bnd-junit-2.1.0-r1.ebuild b/dev-java/bnd-junit/bnd-junit-2.1.0-r1.ebuild
deleted file mode 100644
index eaf475c67bf3..000000000000
--- a/dev-java/bnd-junit/bnd-junit-2.1.0-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-JAVA_PKG_IUSE="test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Junit plugin for bndlib, a swiss army knife for OSGi"
-HOMEPAGE="http://www.aqute.biz/Bnd/Bnd"
-SRC_URI="https://github.com/bndtools/bnd/archive/${PV}.REL.tar.gz -> bndlib-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-CDEPEND="
- dev-java/osgi-core-api:0
- dev-java/bndlib:0"
-
-DEPEND="
- ${CDEPEND}
- >=virtual/jdk-1.5
- test? ( dev-java/junit:4 )"
-
-RDEPEND="
- ${CDEPEND}
- >=virtual/jre-1.5"
-
-S="${WORKDIR}/bnd-${PV}.REL/biz.aQute.junit"
-
-EANT_BUILD_TARGET="build"
-JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_GENTOO_CLASSPATH="bndlib,junit-4,osgi-core-api"
-
-# Tests appear broken and cause a circular dependency.
-RESTRICT="test"
-
-src_prepare() {
- default
- java-pkg_clean
- cp ../cnf/build.xml . || die
-}
-
-src_install() {
- java-pkg_newjar generated/biz.aQute.junit.jar
-}
diff --git a/dev-java/bnd-junit/bnd-junit-2.1.0.ebuild b/dev-java/bnd-junit/bnd-junit-2.1.0.ebuild
deleted file mode 100644
index e4de5405feee..000000000000
--- a/dev-java/bnd-junit/bnd-junit-2.1.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Junit plugin for bndlib, a swiss army knife for OSGi"
-HOMEPAGE="http://www.aqute.biz/Bnd/Bnd"
-SRC_URI="https://github.com/bndtools/bnd/archive/${PV}.REL.tar.gz -> bndlib-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-CDEPEND="
- dev-java/osgi-core-api:0
- dev-java/bndlib:0"
-
-DEPEND=">=virtual/jdk-1.5
- test? ( dev-java/junit:4 )
- ${CDEPEND}"
-
-RDEPEND=">=virtual/jre-1.5
- ${CDEPEND}"
-
-S="${WORKDIR}/bnd-${PV}.REL/biz.aQute.junit"
-
-EANT_BUILD_TARGET="build"
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_GENTOO_CLASSPATH="bndlib,junit-4,osgi-core-api"
-
-# Tests appear broken and cause a circular dependency.
-RESTRICT="test"
-
-java_prepare() {
- # Move the correct build.xml into place, needed for testing.
- cp ../cnf/build.xml . || die
-
- # Remove bundled jar files.
- find . -name '*.jar' -delete > /dev/null
-}
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_newjar generated/biz.aQute.junit.jar
-}