summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-04 22:19:39 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-04 23:09:46 +0100
commitab5f167c678ed099932923b3f7e6e7d3e1349ffd (patch)
tree8a4c53791e5e9096c00b5bcd281746a65c89bbb9
parentdev-python/jsonpointer: Bump to 2.2 (diff)
downloadgentoo-ab5f167c.tar.gz
gentoo-ab5f167c.tar.bz2
gentoo-ab5f167c.zip
dev-python/pbr: Bump to 5.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pbr/Manifest1
-rw-r--r--dev-python/pbr/pbr-5.7.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index 1e6f84d6f3a0..d05cd39bd9e2 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -1 +1,2 @@
DIST pbr-5.6.0.tar.gz 125220 BLAKE2B fc26737857195b0dbe16ecbcbc6e389b53a61105b3bc66e714bb4fcb4907e4329ee7c76b5748fa7d892bf231522e6ff9d414328ae0d97e6262b608c44c737764 SHA512 1dca9020a84e3b9be71fa07e2feb37bbdb2bb69d0b4f69fdcee0fc3c7fe4d84ac2e2079d6bd7560192833f069ca6f5dc27d03a3ef87c168eed18eee8579647fc
+DIST pbr-5.7.0.tar.gz 126776 BLAKE2B ff41c0b3d2354dff065bda4dc9278e42d06accc9fab96bdd734cb462682caf240d1e5d3a6e6c1f52c2986f92d4a1b11b74f5d563a9e8bd5e75aaafe7c3b30108 SHA512 076e6f918db46df74688e749242331161b858def6135d4c9695c24cdfe7db3185169787a6d5555a40a9d0e87ea54000be6419701f162283047bee41f36811535
diff --git a/dev-python/pbr/pbr-5.7.0.ebuild b/dev-python/pbr/pbr-5.7.0.ebuild
new file mode 100644
index 000000000000..a36a0e075381
--- /dev/null
+++ b/dev-python/pbr/pbr-5.7.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="https://github.com/openstack/pbr/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+
+# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
+# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+# stestr is run as external tool
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.3[${PYTHON_USEDEP}]
+ dev-vcs/git
+ ' 'python*')
+ )"
+
+distutils_enable_tests unittest
+
+# This normally actually belongs here.
+python_prepare_all() {
+ # TODO: investigate
+ sed -e s':test_console_script_develop:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -i pbr/tests/test_core.py || die
+ # broken on pypy3
+ # https://bugs.launchpad.net/pbr/+bug/1881479
+ sed -e 's:test_generates_c_extensions:_&:' \
+ -i pbr/tests/test_packaging.py || die
+ rm pbr/tests/test_wsgi.py || die "couldn't remove wsgi network tests"
+ # installs random packages via pip from the Internet
+ sed -e 's:test_requirement_parsing:_&:' \
+ -e 's:test_pep_517_support:_&:' \
+ -i pbr/tests/test_packaging.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if [[ ${EPYTHON} != python* ]]; then
+ einfo "Testing on ${EPYTHON} is not supported at the moment"
+ return
+ fi
+
+ distutils_install_for_testing
+ eunittest -b
+}