summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-16 09:38:33 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-16 12:01:04 +0100
commitab732cf20f58ea846df09d674cee384786395ef0 (patch)
tree1d2caffc45bcc78c3fa52e889dd3d6dce5c87746
parentdev-python/flaky: Enable py3.8 (diff)
downloadgentoo-ab732cf2.tar.gz
gentoo-ab732cf2.tar.bz2
gentoo-ab732cf2.zip
dev-python/nose: Enable py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nose/nose-1.3.7-r4.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/nose/nose-1.3.7-r4.ebuild b/dev-python/nose/nose-1.3.7-r4.ebuild
index 0784e9e84371..333bd6d07d11 100644
--- a/dev-python/nose/nose-1.3.7-r4.ebuild
+++ b/dev-python/nose/nose-1.3.7-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -21,16 +21,22 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~s
IUSE="coverage doc examples test"
RESTRICT="!test? ( test )"
+COVERAGE_IMPLS=( -2 python3_{5,6,7} pypy3 )
REQUIRED_USE="
+ coverage? ( || ( $(python_gen_useflags "${COVERAGE_IMPLS[@]}") ) )
doc? ( || ( $(python_gen_useflags 'python2*') ) )"
RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- coverage? ( dev-python/coverage[${PYTHON_USEDEP}] )"
+ coverage? (
+ $(python_gen_cond_dep 'dev-python/coverage[${PYTHON_USEDEP}]' \
+ "${COVERAGE_IMPLS[@]}")
+ )"
DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )
+ doc? ( >=dev-python/sphinx-0.6[$(python_gen_usedep 'python2*')] )
test? (
- dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/coverage[${PYTHON_USEDEP}]' \
+ "${COVERAGE_IMPLS[@]}")
$(python_gen_cond_dep 'dev-python/twisted[${PYTHON_USEDEP}]' python2_7 python3_{5,6})
)"