summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-23 23:06:16 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-23 23:06:53 +0300
commitab7f57adb0a60bb2399260cbc8a8d1c78a5aa5bd (patch)
tree61aeefc2ae2e7fcb3ac899f0adbdc687dfc89394
parentdev-python/botocore: add 1.27.80 (diff)
downloadgentoo-ab7f57adb0a60bb2399260cbc8a8d1c78a5aa5bd.tar.gz
gentoo-ab7f57adb0a60bb2399260cbc8a8d1c78a5aa5bd.tar.bz2
gentoo-ab7f57adb0a60bb2399260cbc8a8d1c78a5aa5bd.zip
dev-python/boto3: add 1.24.80
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.80.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index bbb8bfacc92b..7366cd322a02 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -10,3 +10,4 @@ DIST boto3-1.24.74.gh.tar.gz 537890 BLAKE2B 5aa5b9fb754b9f0a1da6d05fb8419235617f
DIST boto3-1.24.75.gh.tar.gz 537974 BLAKE2B 00fbaca566c9dc782fa03f11c050477c32a19a1bc5c9e5e6472c99e12844b21e60493b1c1767c4943d600238366d2c30cfb2e67a3e275ce946a5eba6bce4a37c SHA512 0ba05ffa829b59eb983cb75724646f233aa969f032099854c76c736a5aac2a1328f2ec596033d8809d9347b5e7cec4f95ce639b743156fc2c40ee898485875d3
DIST boto3-1.24.78.gh.tar.gz 538770 BLAKE2B ee690bceb7b04a8ef9bd4c3bea2abfa342ec7f5aa5cd60e03f2982f3dfb31a4f38847c687591677442abeb0a7197cb3e1125b3b1674223f165f31eb841968551 SHA512 002b366344be86bf1dccda41d4ae8d2421405de860dcc6e0a6b2889508026f91cfe7bbbfcaca55a59893233e1f7e756527dd0dcc2694f7fc8c9928601ae44fa4
DIST boto3-1.24.79.gh.tar.gz 539152 BLAKE2B 6b700c7100b290d06f261fbf70e56e3242d28af9aa4ea88399123fc0acd504769f29c2979b73e6cf28dee6126f0308b90e6c8d9c684fb2d0f7c08440635c2116 SHA512 c9e1063850979d9b3bc9cee4a530d182b7f2562d1072a67e64990880fa31850ec3f3ef68876a7d430a990c489b80a03c116715064acb4ab4dad444a6ee97d717
+DIST boto3-1.24.80.gh.tar.gz 539716 BLAKE2B ccbbfa84e4e2274eb0275b9b2dcc0a4a78b139007829c4e3f880909f71e404be22c4461b687596bf12675c1212c6cf5b59c4383a042f60cb7919a10581fdc612 SHA512 aa3340e4bb9ae80f02fc70cf2be49d245e3dcc941b0b682c2827c1b8bb51d02e72ab7bf561e7d39397af8ca7ead7e115766fd4fd2eca18db2c551f55afb3e3b6
diff --git a/dev-python/boto3/boto3-1.24.80.ebuild b/dev-python/boto3/boto3-1.24.80.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.80.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}