summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-02-24 00:51:19 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-24 23:17:23 +0100
commitab82b166545f76c18a94f98460b1b5cd6223fd1f (patch)
tree2765601cb1a6f24eb5a67e545305740bf966e549
parentapp-shells/scsh-install-lib: clean up useless variables. (diff)
downloadgentoo-ab82b166545f76c18a94f98460b1b5cd6223fd1f.tar.gz
gentoo-ab82b166545f76c18a94f98460b1b5cd6223fd1f.tar.bz2
gentoo-ab82b166545f76c18a94f98460b1b5cd6223fd1f.zip
app-shells/heirloom-sh: EAPI 6 bump.
Package-Manager: portage-2.3.3
-rw-r--r--app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild b/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
new file mode 100644
index 000000000000..d745244ed744
--- /dev/null
+++ b/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+# slightly broken
+RESTRICT="test"
+
+DESCRIPTION="Heirloom Bourne Shell, derived from OpenSolaris code SVR4/SVID3"
+HOMEPAGE="http://heirloom.sourceforge.net/sh.html"
+SRC_URI="mirror://sourceforge/heirloom/${P}.tar.bz2"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE
+ emake \
+ "CFLAGS=${CFLAGS}" \
+ "CPPFLAGS=${CPPFLAGS}" \
+ "LDFLAGS=${LDFLAGS}" \
+ "LARGEF=" \
+ "CC=$(tc-getCC)"
+}
+
+src_install() {
+ exeinto /bin
+ newexe sh jsh
+ newman sh.1 jsh.1
+}