summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-10-24 00:00:32 +0200
committerPacho Ramos <pacho@gentoo.org>2022-10-24 00:21:48 +0200
commitab8dacfc5ce237174b18ddd331ba4d9b374f68b7 (patch)
tree120e075ffa4f372fdc41e18a15138ccfb7317a7d
parentgames-arcade/rocksndiamonds: add 4.3.2.1 (diff)
downloadgentoo-ab8dacfc.tar.gz
gentoo-ab8dacfc.tar.bz2
gentoo-ab8dacfc.zip
games-strategy/wesnoth: add 1.17.9
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--games-strategy/wesnoth/Manifest1
-rw-r--r--games-strategy/wesnoth/wesnoth-1.17.9.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 46760920e34e..33d60618a5e0 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,2 +1,3 @@
DIST wesnoth-1.16.3.tar.gz 518049863 BLAKE2B e862de2e6f71a1dfe11b0cb6343ea1da78c0eb035893d7bd16ca86586b689b21f39b5266ba86476829c1c9005f7abc37058c2f0ac8ea1ae2970d609880e0da20 SHA512 7f37a1a16ed51ffa935a457553b1a3890398b928bb5893720b746080b37a121a86e21ae402bdddfe30572adccf71a985bf1e3223a0eb443bf7a696ee213d9bf0
DIST wesnoth-1.17.5.tar.bz2 418959651 BLAKE2B 3b6e015192a4050e5d16b25b0e67f91894eeae772125e4bbbefa81082b17fc9c479cf0f4c68d3b74afc5e656c8680319d336d1c14f421f875a64df9b6adbd830 SHA512 7033673f058f3114fcaf9e9b0f5f457c4ed2243fdf04cf80775815d2661bead73d7323c00f4aa678ff82f3d2c23000d81aca97c58f33635060341368ef8c4377
+DIST wesnoth-1.17.9.tar.bz2 420547403 BLAKE2B 8fcef89b72057ce60e292a7a986010f4b0d060e7542ff20029306cde4580473f5e8240f9d99a6248d23147be7a61345a04dca97fa70fb9a1fa039603b8ddd8d9 SHA512 c8f9eb8cc77ea239e710e52a23333636700b34cea5fc8d73d5a62f80d0b58867ee633f556c170700e65e4ad234a69ea1746a1a4148efb64979cf22129ee59157
diff --git a/games-strategy/wesnoth/wesnoth-1.17.9.ebuild b/games-strategy/wesnoth/wesnoth-1.17.9.ebuild
new file mode 100644
index 000000000000..5724bdef29fa
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.17.9.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org
+ https://github.com/wesnoth/wesnoth"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+# uneven minor versions are development versions
+if [[ $(( $(ver_cut 2) % 2 )) == 0 ]] ; then
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+IUSE="dbus dedicated doc nls server"
+
+RDEPEND="
+ acct-group/wesnoth
+ acct-user/wesnoth
+ dev-libs/boost:=[bzip2,context,icu,nls]
+ >=media-libs/libsdl2-2.0.4:0[joystick,video,X]
+ !dedicated? (
+ dev-libs/glib:2
+ dev-libs/openssl:0=
+ >=media-libs/fontconfig-2.4.1
+ >=media-libs/sdl2-image-2.0.0[jpeg,png]
+ >=media-libs/sdl2-mixer-2.0.0[vorbis]
+ media-libs/libvorbis
+ >=x11-libs/pango-1.22.0
+ >=x11-libs/cairo-1.10.0
+ sys-libs/readline:0=
+ dbus? ( sys-apps/dbus )
+ )"
+DEPEND="${RDEPEND}
+ x11-libs/libX11
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if ! use doc ; then
+ sed -i \
+ -e '/manual/d' \
+ doc/CMakeLists.txt || die
+ fi
+
+ # respect LINGUAS (bug #483316)
+ if [[ ${LINGUAS+set} ]] ; then
+ local lang langs=()
+ for lang in $(cat po/LINGUAS) ; do
+ has ${lang} ${LINGUAS} && langs+=( ${lang} )
+ done
+ echo "${langs[@]}" > po/LINGUAS || die
+ fi
+}
+
+src_configure() {
+ filter-flags -ftracer -fomit-frame-pointer
+
+ if use dedicated || use server ; then
+ mycmakeargs=(
+ -DENABLE_CAMPAIGN_SERVER="ON"
+ -DENABLE_SERVER="ON"
+ -DSERVER_UID="${PN}"
+ -DSERVER_GID="${PN}"
+ -DFIFO_DIR="/run/wesnothd"
+ )
+ else
+ mycmakeargs=(
+ -DENABLE_CAMPAIGN_SERVER="OFF"
+ -DENABLE_SERVER="OFF"
+ )
+ fi
+ mycmakeargs+=(
+ -Wno-dev
+ -DENABLE_GAME="$(usex !dedicated)"
+ -DENABLE_DESKTOP_ENTRY="$(usex !dedicated)"
+ -DENABLE_NLS="$(usex nls)"
+ -DENABLE_NOTIFICATIONS="$(usex dbus)"
+ -DENABLE_STRICT_COMPILATION="OFF"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ local DOCS=( README.md changelog.md )
+ cmake_src_install
+ if use dedicated || use server ; then
+ rmdir "${ED}"/run{/wesnothd,} || die
+ newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
+ fi
+}