summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-30 22:17:48 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-30 22:18:12 +1200
commitab8fbdc69892c57035f9b8899bd10c113e02be56 (patch)
tree879a57273686d7f5bba5386fc67aae36c9104b26
parentdev-qt/qtdeclarative: Drop 5.14.2-r3 and 5.15.0 (r0) (diff)
downloadgentoo-ab8fbdc6.tar.gz
gentoo-ab8fbdc6.tar.bz2
gentoo-ab8fbdc6.zip
dev-perl/Digest-CRC: -r bump for EAPI7 & CFLAGS love
- EAPI7 - Ensure CFLAGS passed to make/compiler - Remove unused/empty variable assignments Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Digest-CRC/Digest-CRC-0.220.0_p2-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Digest-CRC/Digest-CRC-0.220.0_p2-r1.ebuild b/dev-perl/Digest-CRC/Digest-CRC-0.220.0_p2-r1.ebuild
new file mode 100644
index 000000000000..05e77aec1088
--- /dev/null
+++ b/dev-perl/Digest-CRC/Digest-CRC-0.220.0_p2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=OLIMAUL
+# https://rt.cpan.org/Ticket/Display.html?id=120669
+DIST_VERSION=0.22.2
+inherit perl-module
+S="${WORKDIR}/${PN}-0.22"
+
+DESCRIPTION="Generic CRC function"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}