summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-16 17:55:03 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-16 19:38:08 -0600
commitaba4f15d8655b82ecd2bcfe7e97860e5f4d748ca (patch)
tree1eb774e626837f434fd20c29ad6d09271dbc4d8a
parentdev-python/oslo-cache: 1.28.0 bup (diff)
downloadgentoo-aba4f15d8655b82ecd2bcfe7e97860e5f4d748ca.tar.gz
gentoo-aba4f15d8655b82ecd2bcfe7e97860e5f4d748ca.tar.bz2
gentoo-aba4f15d8655b82ecd2bcfe7e97860e5f4d748ca.zip
dev-python/oslo-concurrency: 3.25.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/oslo-concurrency/Manifest1
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-3.25.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index b80c3e46b713..3fb2baa590ea 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1 +1,2 @@
DIST oslo.concurrency-3.21.1.tar.gz 48866 BLAKE2B b621548173e30e7a7f3683d1f5ef3821574e780d1df99c91d8bb77d4e3d3280da395066be7c9ec95b3d3e640da694aae81943e126c8c4e6cd5f18c2db99efba6 SHA512 6d165ebf952b29d96d2d1a8b938b2ef4746c77b99a62ca596ee93e6fb6d919f183eede380763b6167cb7d372e03803556715523b7a63ad1dbadff4eede7c0bcd
+DIST oslo.concurrency-3.25.0.tar.gz 48736 BLAKE2B fe8506599d175d22c44fd52bb2c4e5f238687ba7eeb926d3f042be14e6ef8cecb3c13b010c1540c835d9bc7e587560ea391ea00b99f05553d6bfd46d2bbe3d9c SHA512 0273112cdc0a1de45ec231b672f2ed8f8fe5842dea756bc062a18247036b2fdbfbce392f3edbfbb871a2bda94412f6c82f3a634fd98a77c1df5a243babcbd4de
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-3.25.0.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-3.25.0.ebuild
new file mode 100644
index 000000000000..b0254407070b
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-3.25.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="library for running multi-thread, multi-process applications"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.concurrency"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.concurrency/oslo.concurrency-${PV}.tar.gz"
+S="${WORKDIR}/oslo.concurrency-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^futures/d' test-requirements.txt || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests ${PN/-/_}/tests/ || die "test failed under ${EPYTHON}"
+}