summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2020-10-14 02:14:46 +0200
committerMaciej Mrozowski <reavertm@gentoo.org>2020-10-14 02:15:30 +0200
commitabbe61529421e9526d876abb1d022fd94efba0ae (patch)
treea745ea400645b4dcda9b72db3c729b736f1f3238
parentapp-text/mupdf: add additional security patches (diff)
downloadgentoo-abbe61529421e9526d876abb1d022fd94efba0ae.tar.gz
gentoo-abbe61529421e9526d876abb1d022fd94efba0ae.tar.bz2
gentoo-abbe61529421e9526d876abb1d022fd94efba0ae.zip
dev-libs/injeqt: no Werror
Closes: https://bugs.gentoo.org/747577 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Maciej Mrozowski <reavertm@gentoo.org>
-rw-r--r--dev-libs/injeqt/files/injeqt-1.2.0-no-Werror.patch12
-rw-r--r--dev-libs/injeqt/injeqt-1.2.0.ebuild7
2 files changed, 17 insertions, 2 deletions
diff --git a/dev-libs/injeqt/files/injeqt-1.2.0-no-Werror.patch b/dev-libs/injeqt/files/injeqt-1.2.0-no-Werror.patch
new file mode 100644
index 000000000000..ffb8aae9b1b7
--- /dev/null
+++ b/dev-libs/injeqt/files/injeqt-1.2.0-no-Werror.patch
@@ -0,0 +1,12 @@
+diff -ruN injeqt-1.2.0/CMakeLists.txt injeqt-my/CMakeLists.txt
+--- injeqt-1.2.0/CMakeLists.txt 2017-04-21 11:40:08.000000000 +0200
++++ injeqt-my/CMakeLists.txt 2020-10-14 02:04:12.645803149 +0200
+@@ -37,7 +37,7 @@
+ cmake_policy (SET CMP0043 NEW)
+ endif ()
+
+-set (WARNINGS "-Werror -W -Wall -Wextra -Wundef -Wunused -Wuninitialized -Wcast-align -Wpointer-arith -Woverloaded-virtual -Wnon-virtual-dtor -fno-common")
++set (WARNINGS "-W -Wall -Wextra -Wundef -Wunused -Wuninitialized -Wcast-align -Wpointer-arith -Woverloaded-virtual -Wnon-virtual-dtor -fno-common")
+ set (VISIBILITY "-fvisibility=hidden -fvisibility-inlines-hidden")
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 ${WARNINGS} ${VISIBILITY}")
+
diff --git a/dev-libs/injeqt/injeqt-1.2.0.ebuild b/dev-libs/injeqt/injeqt-1.2.0.ebuild
index 3d9de6be309d..42410678e47c 100644
--- a/dev-libs/injeqt/injeqt-1.2.0.ebuild
+++ b/dev-libs/injeqt/injeqt-1.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,7 +24,10 @@ DEPEND="${RDEPEND}
# https://github.com/vogel/injeqt/issues/18
RESTRICT=test
-PATCHES=( "${FILESDIR}/${P}-gcc7.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-gcc7.patch"
+ "${FILESDIR}/${PN}-1.2.0-no-Werror.patch"
+)
src_configure() {
local mycmakeargs=(