summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-27 11:22:06 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-27 11:22:06 -0500
commitabda111ae4d1b6d2dba3b5e3963a09222f309265 (patch)
tree3b8adc4d9f13838b5c418a2e35897bddaa00f277
parentdev-db/mariadb: Drop security vulnerable version (diff)
downloadgentoo-abda111a.tar.gz
gentoo-abda111a.tar.bz2
gentoo-abda111a.zip
dev-php/PEAR-PEAR_PackageFileManager_Plugins: New package
Required dependency for dev-php/PEAR-PEAR_PackageFileManager Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-php/PEAR-PEAR_PackageFileManager_Plugins/Manifest1
-rw-r--r--dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4.ebuild40
-rw-r--r--dev-php/PEAR-PEAR_PackageFileManager_Plugins/metadata.xml8
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/PEAR-PEAR_PackageFileManager_Plugins/Manifest b/dev-php/PEAR-PEAR_PackageFileManager_Plugins/Manifest
new file mode 100644
index 000000000000..ed6c6df710b9
--- /dev/null
+++ b/dev-php/PEAR-PEAR_PackageFileManager_Plugins/Manifest
@@ -0,0 +1 @@
+DIST PEAR_PackageFileManager_Plugins-1.0.4.tgz 20967 SHA256 58ac5018bb5edf0b76df35474ba38ea1e98f2d9e30ea530fa1ee8c756f1aac03 SHA512 7461ba3dc6f51263383136041d217e2d0d7607c5ef9f8766e08466118f2c869a037622750dd7bdcbbf2a114efde096b3192bbf5229f62ea42adfe83d36451fa0 WHIRLPOOL 623240224078018eab1dc86b24ed2c9f31af2723cb63cf3504df9b66b68bb79dff7466dbea4f7266f6fb56f60af33037fba3607bfe2a5ad26103d8c1a4d82d34
diff --git a/dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4.ebuild b/dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4.ebuild
new file mode 100644
index 000000000000..96cb66c4c449
--- /dev/null
+++ b/dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+DESCRIPTION="Various methods to check files to update an existing package.xml file"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-php/PEAR-PEAR-1.10.1
+ >=dev-php/PEAR-XML_Serializer-0.19.0
+ >=dev-lang/php-5.3:*[xml,simplexml]"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r PEAR
+}
+
+pkg_postinst() {
+ # Register the package from the package.xml file
+ # Operation is not critical so die is not required
+ if [[ -f "${WORKDIR}/package.xml" ]] ; then
+ "${EROOT}usr/bin/peardev" install -nrO --force "${WORKDIR}/package.xml" 2> /dev/null
+ fi
+}
+
+pkg_postrm() {
+ # Uninstall known dependency
+ "${EROOT}usr/bin/peardev" uninstall -nrO "pear.php.net/${MY_PN}"
+}
diff --git a/dev-php/PEAR-PEAR_PackageFileManager_Plugins/metadata.xml b/dev-php/PEAR-PEAR_PackageFileManager_Plugins/metadata.xml
new file mode 100644
index 000000000000..aca42932b833
--- /dev/null
+++ b/dev-php/PEAR-PEAR_PackageFileManager_Plugins/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+</maintainer>
+</pkgmetadata>