summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-20 13:53:32 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-20 13:53:57 -0800
commitabdbe7ce4786e9cd57da0ab3964ca2f7b7dfc450 (patch)
treedba3fd6d087b7423899791787764e516fd507b53
parentdev-qt/qtgui: Fix build with -xcb and -no-libinput (diff)
downloadgentoo-abdbe7ce4786e9cd57da0ab3964ca2f7b7dfc450.tar.gz
gentoo-abdbe7ce4786e9cd57da0ab3964ca2f7b7dfc450.tar.bz2
gentoo-abdbe7ce4786e9cd57da0ab3964ca2f7b7dfc450.zip
dev-python/toml: Revbump, enable tests, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/toml/Manifest2
-rw-r--r--dev-python/toml/files/toml-0.10.0-depricationwarning.patch19
-rw-r--r--dev-python/toml/toml-0.10.0-r1.ebuild43
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/toml/Manifest b/dev-python/toml/Manifest
index 89d930e04081..198c28c58bd5 100644
--- a/dev-python/toml/Manifest
+++ b/dev-python/toml/Manifest
@@ -1 +1,3 @@
+DIST toml-0.10.0-1.tar.gz 20396 BLAKE2B 3ddcb4cadfc68239cfcb34938a785b27326991ea89966aa6ba3ff2c8a430099664dce1474adf453f2d372b0d149c43584bce9c7abee4c8cbec3126adb3d2ab95 SHA512 ebad9d87606cf66f3db5abb2b0abd333d5536037446df131bda3f8138c33a6495a8923fc583328c27632d39448790e0e6788745d8acd7d600ea3ce57cb7dbd45
DIST toml-0.10.0.tar.gz 16719 BLAKE2B f7863e9cf0ca5185a59d64010346b4b960c40bc3711d4cbd1ad907d15da823319b748df1a5536465e9f36428bf1599624ede3b1fa68cb420684a52ba137227c9 SHA512 26f26c38ce9cd48305218c2c34c5a5407b00aefc25a933f044bb7be22c23cfdfa3b8cf2da952d17760c4b9038df62e405fa039cc7b63dd3e94c9c312f04f9182
+DIST toml-test-39bb76d631ba103a94b377aaf52c979456677fb1.tar.gz 19304 BLAKE2B 5bb73ff91146ee85f6844132cdfc06673cdb384810c6c978cfc9f8ce6ba8b1607a0dc2d03aa868791d5fd33d00ebac96a4cd57a98948a3ef9318a52417904eda SHA512 931ba91b77da576979bde290c99f6cb1a2eeec3aee55b5041b0216094c584934d560487d329df21caa64b405ec50b4dd417dc910bbe4f15b1440686efc58da29
diff --git a/dev-python/toml/files/toml-0.10.0-depricationwarning.patch b/dev-python/toml/files/toml-0.10.0-depricationwarning.patch
new file mode 100644
index 000000000000..6afcea90a5b1
--- /dev/null
+++ b/dev-python/toml/files/toml-0.10.0-depricationwarning.patch
@@ -0,0 +1,19 @@
+commit 660dd2d57278e6f608bbaedcaaa4529ace557e41
+Author: Tsuyoshi Hombashi <tsuyoshi.hombashi@gmail.com>
+Date: Mon Oct 8 23:32:53 2018 +0900
+
+ Change to avoid "DeprecationWarning: invalid escape sequence"
+
+diff --git a/toml/decoder.py b/toml/decoder.py
+index bed551b..aa468f2 100644
+--- a/toml/decoder.py
++++ b/toml/decoder.py
+@@ -44,7 +44,7 @@ except NameError:
+ FNFError = IOError
+
+
+-TIME_RE = re.compile("([0-9]{2}):([0-9]{2}):([0-9]{2})(\.([0-9]{3,6}))?")
++TIME_RE = re.compile(r"([0-9]{2}):([0-9]{2}):([0-9]{2})(\.([0-9]{3,6}))?")
+
+
+ class TomlDecodeError(ValueError):
diff --git a/dev-python/toml/toml-0.10.0-r1.ebuild b/dev-python/toml/toml-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..c0d855b0f8b4
--- /dev/null
+++ b/dev-python/toml/toml-0.10.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+TOML_TEST_VER="39bb76d631ba103a94b377aaf52c979456677fb1"
+
+DESCRIPTION="Python library for handling TOML files"
+HOMEPAGE="https://github.com/uiri/toml"
+SRC_URI="https://github.com/uiri/${PN}/archive/${PV}.tar.gz -> ${P}-1.tar.gz
+ test? ( https://github.com/BurntSushi/toml-test/archive/${TOML_TEST_VER}.tar.gz -> toml-test-${TOML_TEST_VER}.tar.gz )"
+IUSE="test"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~sparc ~x86"
+
+# peculiar testing depending on https://github.com/BurntSushi/toml-test. Not
+# particularly worth the trouble.
+#RESTRICT="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python3*') )"
+
+PATCHES=(
+ "${FILESDIR}/toml-0.10.0-depricationwarning.patch"
+)
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if use test; then
+ mv "${WORKDIR}/toml-test-${TOML_TEST_VER#v}" "${S}/toml-test" || die
+ fi
+
+ distutils-r1_python_prepare_all
+}