summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-04 17:55:08 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-04 18:22:14 +0200
commitac2ab96aef096314918ec90fd65598674b9cce88 (patch)
tree1283271111eedcac36d7d99623ce1e54795f9e03
parentdev-python/arrow: Bump to 1.2.3 (diff)
downloadgentoo-ac2ab96a.tar.gz
gentoo-ac2ab96a.tar.bz2
gentoo-ac2ab96a.zip
dev-python/tqdm: Bump to 4.64.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.64.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index dba4b9568441..755a43b58b8d 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1 +1,2 @@
DIST tqdm-4.64.0.tar.gz 169499 BLAKE2B a6b9587a366c026716c63af4358ddba693b52be3490a161071bc750fffcd50429bc639255635d96c950a130d9fe994dc2abc98f3fbaf0a0c344140c8ae972596 SHA512 84d243b86ea3665e915e6a79e7887a4d0487b166971d211e34229b7a46429f4e4f5808c03f24420b20fb85d274e1e6b36ed852af99c5c9d177c8ce71f0ce0c17
+DIST tqdm-4.64.1.tar.gz 169599 BLAKE2B 4c48f647beb46f22e3c065e2e9c1dc29755c74a2fd29cb8ad8b0dfeab529499d0fbca9296d06453012b3bbf9f9870f95da5e2f37f4c8ba29a71cbee3bd15116b SHA512 bc7ab34145722229737d25d87895c8760b82271c345e1174c83f5896cc893f92a27901d83575472ad124329acdad69bd21e7d68e79aeeefb0e66c83b11989d18
diff --git a/dev-python/tqdm/tqdm-4.64.1.ebuild b/dev-python/tqdm/tqdm-4.64.1.ebuild
new file mode 100644
index 000000000000..79761eab6850
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.64.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="
+ https://github.com/tqdm/tqdm/
+ https://pypi.org/project/tqdm/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Skip unpredictable performance tests
+ tests/tests_perf.py
+)
+
+python_install_all() {
+ doman tqdm/tqdm.1
+ newbashcomp tqdm/completion.sh tqdm
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}